Bug 1640701 - GNOME Software "update and restart" button appears to do nothing
Summary: GNOME Software "update and restart" button appears to do nothing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-10-18 14:38 UTC by Stephen Gallagher
Modified: 2018-10-26 11:51 UTC (History)
11 users (show)

Fixed In Version: gnome-software-3.30.5-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-26 11:51:05 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of the cancel button (42.98 KB, image/png)
2018-10-18 14:38 UTC, Stephen Gallagher
no flags Details
progress bar in gnome-software (117.78 KB, image/png)
2018-10-24 17:53 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1642878 None CLOSED previous update info is leaking into current update info 2019-09-09 08:27:57 UTC
Red Hat Bugzilla 1643059 None CLOSED Download button performs the download, but then changes back to Download 2019-09-09 08:27:57 UTC
Red Hat Bugzilla 1643444 None CLOSED refresh button doesn't refresh the repos, pkcon helps 2019-09-09 08:27:57 UTC
Red Hat Bugzilla 1643446 None NEW download progress is often invisible 2019-09-09 08:27:57 UTC

Internal Links: 1642878 1643059 1643444 1643446

Description Stephen Gallagher 2018-10-18 14:38:10 UTC
Created attachment 1495315 [details]
Screenshot of the cancel button

Description of problem:


Version-Release number of selected component (if applicable):
gnome-software-3.30.3-1.fc29.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Have a Fedora 29 Workstation
2. Have some updates waiting to be applied.
3. Open GNOME Software and navigate to the updates tab.
4. Click on the "update and restart" button.

Actual results:
The button changes to a "cancel" button. Nothing happens for at least a few minutes. Clicking cancel aborts whatever it was doing.

Expected results:
Some sort of progress should be indicated and the system should reboot to apply updates.

Additional info:
Kalev tells me that it's a UX problem and that if I waited long enough, it would eventually complete. I waited at least five minutes; that's long enough for a user to assume that the process has hung.

Comment 1 Fedora Blocker Bugs Application 2018-10-18 14:40:18 UTC
Proposed as a Blocker for 29-final by Fedora user sgallagh using the blocker tracking app because:

 "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)."

While it's possible that this will work if left alone long enough, most users are going to assume after several minutes that this is broken.

Comment 2 Geoffrey Marr 2018-10-18 21:40:24 UTC
Discussed during the 2018-10-18 Fedora 29 Go/No-Go meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops."

[1] https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2018-10-18/f29-final-go_no_go-meeting.2018-10-18-17.00.log.txt

Comment 3 Kamil Páral 2018-10-23 12:19:25 UTC
I can confirm this behavior. When you click Update&Restart, the repos are getting refreshed and packages are getting downloaded, which takes a long time (perhaps if updates are downloaded in background, this is not needed, but if you manually refresh the updates, this is what happens). However, the progress bar is somehow bugged and doesn't update properly (seems to be at 100% almost all the time), and on top of that, the progress bar is almost invisible (a single pixel line at the bottom of the Cancel button). All together it seems like gnome-software is stuck and not doing anything.

Comment 4 Lukas Ruzicka 2018-10-23 13:26:42 UTC
Yes, I agree with Comment 3. This bug is not about functionality, rather about usability.

Comment 5 Kalev Lember 2018-10-23 13:42:35 UTC
Upstream merge request: https://gitlab.gnome.org/GNOME/gnome-software/merge_requests/128

Comment 6 Matthew Miller 2018-10-23 15:00:19 UTC
On my system right now, with gnome-software-3.30.3-1.fc29.x86_64, when I push the Restart & Update, I get the restart dialog after several minutes, but then when I push "Restart & Isntall", I am returned to the desktop with nothing happening.

Comment 7 Fedora Update System 2018-10-24 13:21:24 UTC
libappstream-glib-0.7.14-2.fc29 gnome-software-3.30.5-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b5a870dcff

Comment 8 Lukas Ruzicka 2018-10-24 15:22:42 UTC
The update works for me, however, this does not solve the bug #1640701. The button changed to Download, which makes sense, but then I still see no progress or activity and I do not know whether packages are being downloaded or gnome-software got stalled. @frantisekz told me he would see the progress bar under the Cancel button in adwaita dark theme. I did not see anything in standard gnome theme. This should be fixed to work for everyone.

Comment 9 Fedora Update System 2018-10-24 15:41:17 UTC
gnome-software-3.30.5-1.fc29, libappstream-glib-0.7.14-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b5a870dcff

Comment 10 Kamil Páral 2018-10-24 17:52:41 UTC
I can also confirm the progress bar is not fixed for me with the new version. It behaves the same as before, an almost complete progress bar is just a few pixels wide. I'll attach a screenshot.

Furthermore, the refresh button doesn't refresh the repos, just reloads the existing caches (probably). After enabling updates-testing (to see some updates), I had to run "pkcon refresh force", because the refresh button took just a few seconds and didn't display the new updates. I don't know whether this is a recent regression, though, or even an expected behavior.

I've also seen a case where gnome-software showed no available updates even after "pkcon refresh force", but dnf update showed many more available. I was only able to solve that by completely pruning /var/cache/PackageKit. Unfortunately I'm not able to reproduce it right now.

Comment 11 Kamil Páral 2018-10-24 17:53:09 UTC
Created attachment 1497140 [details]
progress bar in gnome-software

Comment 12 Geoffrey Marr 2018-10-24 18:05:30 UTC
Tested by installing "System Updates" through gnome-software. Hit the "Update" button, was presented with a cancel button with a progress bar underneath, indicating progress. Then was presented with a "Restart and Install" button, which worked as expected. Note that I am using the standard gnome theme.

However, I have just noticed that the "Refresh" button does not actually refresh the packages in the repos, like Kamil's experience in comment 10. 

Unlike Kamil's experience though, my progress bar is a full-button-wide progress bar and behaves as one would expect it to.

Comment 13 Kalev Lember 2018-10-25 05:23:44 UTC
Thanks for the testing! I'll see how many of those I can fix in a few days :) Richard is on vacation so it's just me working on this right now.

I think of all the issues reported, pschindl's issue in the Bodhi ticket seems the most worrying as it can actually break updates without any way out:

"I updated gnome-software and libappstream-glib and restarted. I downgraded gnome-calculator. Gnome-software updated updates and found update for g-c, but when I click on Download button it just blinks and nothing happens (even pkmon shows no action). So I can't update because there is still Download button and there is no 'Restart & update' button. With this version I'm unable to update."

If it came to a question "is this good enough to ship in F29 GA", I think I could close an eye to the progress bar issues, but not pschindl's issue, I think that needs investigating/fixing. This seems a bit too fragile right now.

Comment 14 Kamil Páral 2018-10-25 09:23:24 UTC
I found a graphical glitch in gnome-software that causes extra packages to be displayed in available updates, see bug 1642878. I'm not sure whether it explains some of those errors mentioned here. I know for a fact that I had the opposite problem twice, gnome-software showing fewer (or no) updates than actually available, even after "pkconf refresh force". But I can't reproduce that right now.

Comment 15 Kalev Lember 2018-10-25 10:21:50 UTC
(In reply to Kamil Páral from comment #10)
> Furthermore, the refresh button doesn't refresh the repos, just reloads the
> existing caches (probably). After enabling updates-testing (to see some
> updates), I had to run "pkcon refresh force", because the refresh button
> took just a few seconds and didn't display the new updates. I don't know
> whether this is a recent regression, though, or even an expected behavior.

This should be fixed in https://gitlab.gnome.org/GNOME/gnome-software/commit/4e3dd2e94917742b111bbf860d0059116de7c973 (just a branch now, I'll play with this some more before pushing to master)

Comment 16 Kamil Páral 2018-10-25 11:49:16 UTC
(In reply to Kalev Lember from comment #13)
> "I updated gnome-software and libappstream-glib and restarted. I downgraded
> gnome-calculator. Gnome-software updated updates and found update for g-c,
> but when I click on Download button it just blinks and nothing happens (even
> pkmon shows no action). So I can't update because there is still Download
> button and there is no 'Restart & update' button. With this version I'm
> unable to update."

I've seen this as well, Download going to Cancel (downloading) and then back to Download. After I rebooted, it was immediately changed to Restart&Update. However, I saw this with older dnf (dnf 3.6.1) and Petr was also using an older dnf. So it's possible this was caused by some bug in libdnf that was already fixed (there have been many fixes since then). I'd be concerned about this only if somebody could reproduce it with latest dnf.

Comment 17 Kalev Lember 2018-10-25 12:07:34 UTC
This shouldn't have anything to do with the dnf version. If it fails to transition from "Download" to "Restart & Update" then it's some kind of state keeping inside gnome-software going wrong.

Comment 18 Kamil Páral 2018-10-26 09:35:31 UTC
The core issue here has been fixed by gnome-software-3.30.5-1.fc29. There is now a Download button for the downloading phase. The other issues mentioned in this report have been split into individual reports here:
https://bugzilla.redhat.com/show_bug.cgi?id=1643059
https://bugzilla.redhat.com/show_bug.cgi?id=1643444
https://bugzilla.redhat.com/show_bug.cgi?id=1643446
https://bugzilla.redhat.com/show_bug.cgi?id=1642878

Comment 19 Fedora Update System 2018-10-26 11:51:05 UTC
gnome-software-3.30.5-1.fc29, libappstream-glib-0.7.14-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.