Bug 164341 - firefox doesn't start
firefox doesn't start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 164342 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 23:52 EDT by sean
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 09:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2005-07-26 23:52:31 EDT
Description of problem:

[system@amd64-3000 firefox-1.1]$ firefox
[system@amd64-3000 firefox-1.1]$ ./firefox-bin
./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open
shared object file: No such file or directory
[system@amd64-3000 firefox-1.1]$ ls -l libmozjs.so
-rwxr-xr-x  1 root root 673216 Jul 23 02:27 libmozjs.so
[system@amd64-3000 firefox-1.1]$ rpm -q firefox
firefox-1.1-0.2.4.deerpark.alpha2

Version-Release number of selected component (if applicable):

firefox-1.1-0.2.4.deerpark.alpha2

How reproducible:

As above

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:

See above
Expected results:

firefox
Additional info:
Comment 1 sean 2005-08-01 22:52:10 EDT
Tried firefox-1.1-0.2.5.deerpark.alpha2.

Same result.
Comment 2 Rahul Sundaram 2005-08-13 16:10:40 EDT
*** Bug 164342 has been marked as a duplicate of this bug. ***
Comment 3 Rahul Sundaram 2005-08-13 16:16:22 EDT
I cant reproduce this on a x86 system on the same firefox version. 
Comment 4 sean 2005-08-14 21:11:29 EDT
Well it doesn't work on this x86_64 machine:


rpm -q firefox
firefox-1.1-0.2.5.deerpark.alpha2
$ firefox
$ sh -x /usr/bin/firefox
++ basename /usr/bin/firefox
+ cmdname=firefox
+ MOZ_LIB_DIR=/usr/lib
+ '[' -x /usr/lib64/firefox-1.1/firefox-bin ']'
+ MOZ_LIB_DIR=/usr/lib64
+ MOZ_DIST_BIN=/usr/lib64/firefox-1.1
+ MOZ_PROGRAM=/usr/lib64/firefox-1.1/firefox
+ MOZ_CLIENT_PROGRAM=/usr/lib64/firefox-1.1/mozilla-xremote-client
+ MOZ_CLIENT_PROGRAM_PARAM='-a firefox'
+ MOZILLA_FIVE_HOME=/usr/lib64/firefox-1.1
+ export MOZILLA_FIVE_HOME
+ '[' '' ']'
+ LD_LIBRARY_PATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1/plugins
+ export LD_LIBRARY_PATH
+ '[' '' ']'
+ MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins:/usr/lib64/firefox-1.1/plugins
+ export MOZ_PLUGIN_PATH
+ FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox-1.1/res/Xft
+ export FONTCONFIG_PATH
++ check_running
++ /usr/lib64/firefox-1.1/mozilla-xremote-client -a firefox 'ping()'
++ RETURN_VAL=2
++ '[' 2 -eq 2 ']'
++ echo 0
++ return 0
+ ALREADY_RUNNING=0
+ '[' 0 -eq 1 ']'
+ MOZARGS=
++ echo en_US.UTF-8
++ sed 's|_\([^.]*\).*|-\1|g'
+ MOZLOCALE=en-US
+ '[' -f /usr/lib64/firefox-1.1/chrome/en-US.jar ']'
+ MOZARGS='-UILocale en-US'
+ '[' -z '' ']'
+ exec /usr/lib64/firefox-1.1/firefox -UILocale en-US

$ sh -x /usr/lib64/firefox-1.1/firefox -UILocale en-US
+ moz_libdir=/usr/local/lib/firefox-1.0+
+ MRE_HOME=/usr/local/lib/mre/mre-1.0+
+ found=0
+ progname=/usr/lib64/firefox-1.1/firefox
++ dirname /usr/lib64/firefox-1.1/firefox
+ curdir=/usr/lib64/firefox-1.1
++ basename /usr/lib64/firefox-1.1/firefox
+ progbase=firefox
+ run_moz=/usr/lib64/firefox-1.1/run-mozilla.sh
+ test -x /usr/lib64/firefox-1.1/run-mozilla.sh
+ dist_bin=/usr/lib64/firefox-1.1
+ found=1
+ '[' 1 = 0 ']'
+ script_args=
+ moreargs=
+ debugging=0
+ MOZILLA_BIN=firefox-bin
+ '[' linux-gnu = beos ']'
+ '[' 2 -gt 0 ']'
+ case "$1" in
+ moreargs=' "-UILocale"'
+ shift 1
+ '[' 1 -gt 0 ']'
+ case "$1" in
+ moreargs=' "-UILocale" "en-US"'
+ shift 1
+ '[' 0 -gt 0 ']'
+ export MRE_HOME
+ eval 'set --  "-UILocale" "en-US"'
++ set -- -UILocale en-US
+ moz_pis_startstop_scripts start
+ MOZ_USER_DIR=.mozilla/firefox
+ MOZ_PIS_API=2
+ MOZ_PIS_MOZBINDIR=/usr/lib64/firefox-1.1
+ MOZ_PIS_SESSION_PID=26135
+ MOZ_PIS_USER_DIR=.mozilla/firefox
+ export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID MOZ_PIS_USER_DIR
+ case "${1}" in
+ for curr_pis in '"${dist_bin}/init.d"/S*' '"${HOME}/${MOZ_USER_DIR}/init.d"/S*'
+ '[' -x '/usr/lib64/firefox-1.1/init.d/S*' ']'
+ for curr_pis in '"${dist_bin}/init.d"/S*' '"${HOME}/${MOZ_USER_DIR}/init.d"/S*'
+ '[' -x '/root/.mozilla/firefox/init.d/S*' ']'
+ '[' 0 = 1 ']'
+ /usr/lib64/firefox-1.1/run-mozilla.sh /usr/lib64/firefox-1.1/firefox-bin
-UILocale en-US
+ exitcode=1
+ moz_pis_startstop_scripts stop
+ MOZ_USER_DIR=.mozilla/firefox
+ MOZ_PIS_API=2
+ MOZ_PIS_MOZBINDIR=/usr/lib64/firefox-1.1
+ MOZ_PIS_SESSION_PID=26135
+ MOZ_PIS_USER_DIR=.mozilla/firefox
+ export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID MOZ_PIS_USER_DIR
+ case "${1}" in
+ for curr_pis in '"${HOME}/${MOZ_USER_DIR}/init.d"/K*' '"${dist_bin}/init.d"/K*'
+ '[' -x '/root/.mozilla/firefox/init.d/K*' ']'
+ for curr_pis in '"${HOME}/${MOZ_USER_DIR}/init.d"/K*' '"${dist_bin}/init.d"/K*'
+ '[' -x '/usr/lib64/firefox-1.1/init.d/K*' ']'
+ exit 1


and then:

$  sh -x /usr/lib64/firefox-1.1/run-mozilla.sh
/usr/lib64/firefox-1.1/firefox-bin -UILocale en-US
++ basename /usr/lib64/firefox-1.1/run-mozilla.sh
+ cmdname=run-mozilla.sh
++ dirname /usr/lib64/firefox-1.1/run-mozilla.sh
+ MOZ_DIST_BIN=/usr/lib64/firefox-1.1
+ MOZ_DEFAULT_NAME=./run-mozilla.sh-bin
+ MOZ_APPRUNNER_NAME=./mozilla-bin
+ MOZ_VIEWER_NAME=./viewer
+ MOZ_PROGRAM=
+ exitcode=0
+ moz_debug=0
+ moz_debugger=
+ '[' 3 -gt 0 ']'
+ case $1 in
+ break
+ '[' 3 -gt 0 ']'
+ MOZ_PROGRAM=/usr/lib64/firefox-1.1/firefox-bin
+ shift
+ '[' -z /usr/lib64/firefox-1.1/firefox-bin ']'
+ '[' '!' -x /usr/lib64/firefox-1.1/firefox-bin ']'
+ MOZILLA_FIVE_HOME=/usr/lib64/firefox-1.1
+ '[' -z '' ']'
+ MRE_HOME=/usr/lib64/firefox-1.1
+
LD_LIBRARY_PATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1/plugins:/usr/lib64/firefox-1.1
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ SHLIB_PATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1
+ LIBPATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1
+ DYLD_LIBRARY_PATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1
+
LIBRARY_PATH=/usr/lib64/firefox-1.1:/usr/lib64/firefox-1.1/components:/usr/lib64/firefox-1.1
+ ADDON_PATH=/usr/lib64/firefox-1.1
+ '[' '' = '' ']'
+ XSUNTRANSPORT=shmem
+ XSUNSMESIZE=512
+ export XSUNTRANSPORT XSUNSMESIZE
+ '[' '' = '' ']'
+ '[' -f /etc/init.d/xprint ']'
+ '[' 0 -eq 1 ']'
+ export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
+ export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
+ '[' 0 -eq 1 ']'
+ moz_run_program -UILocale en-US
+ prog=/usr/lib64/firefox-1.1/firefox-bin
+ '[' '!' -x /usr/lib64/firefox-1.1/firefox-bin ']'
+ moz_test_binary /bin/type
+ binary=/bin/type
+ '[' -f /bin/type ']'
+ return 0
+ '[' 0 -eq 1 ']'
++ which md5sum
+ crc_prog=/usr/bin/md5sum
+ '[' -x /usr/bin/md5sum ']'
+ DEBUG_CORE_FILES=1
+ '[' 1 ']'
+ crc_old=
+ '[' -f core ']'
+ /usr/lib64/firefox-1.1/firefox-bin -UILocale en-US
+ exitcode=1
+ '[' 1 ']'
+ '[' -f core ']'
+ '[' '' '!=' '' ']'
+ exit 1


And if I try to run the binary, I get libmozjs.so not found.

Is there anything else that would be helpful?
Comment 5 John Ellson 2005-08-17 08:59:56 EDT
Same problem here, also on x86_64.

Reverting to firefox-1.1-0.2.5.deerpark.alpha2.x86_64.rpm fixes the problem.
Comment 6 sean 2005-08-19 12:28:15 EDT
 rpm -q firefox
firefox-1.1-0.2.7.deerpark.alpha2.1

Still doesn't start.

FWIW, I played with disabling pango (and enabling ) in the startup script.
Comment 7 sean 2005-08-29 21:37:27 EDT
 rpm -q firefox
firefox-1.1-0.2.8.deerpark.alpha2

Still doesn't start.

Am I the only one who can't start firefox on x86_64?
Comment 8 Ola Thoresen 2005-09-22 03:03:46 EDT
See also Bug 167228

I bit more of stracing shows this, that might be a reason?

[pid  5575] write(3, "\16\0\2\0,\0`\2", 8) = 8
[pid  5575] read(3, 
"\1\30\344\1\0\0\0\0H\0\0\0\0\0\0\0\310\0\310\0\0\0\0\0\240\21\37\1\0\0\0\0", 
32) = 32
[pid  5575] writev(2, [{"/usr/lib64/firefox-1.5/firefox-bin", 34}, {": ", 2}, 
{"symbol lookup error", 19}, {": ", 2}, {"/usr/lib64/firefox-1.5/components/
libnecko.so", 45}, {": ", 2}, {"undefined symbol: PR_GetPhysicalMemorySize", 42
}, {"", 0}, {"", 0}, {"\n", 1}], 10) = 147
[pid  5575] exit_group(127)             = ?
Comment 9 sean 2005-09-23 19:15:08 EDT
FWIW,
firefox-1.5-0.5.0.beta1
now Works For Me on amd64.

Comment 10 Ola Thoresen 2005-09-26 04:18:49 EDT
GOT IT!

Initally, it did not work here either.
Then i did some deep digging, and realized I had the following installed:

]$ rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" | grep nspr
mozilla-nspr-1.7.10-1.5.1.x86_64
nspr-4.6-4.i386

simply doing a "yum install nspr.x86_64" replaced the old mozilla-nspr and that 
solved the problem.


Note You need to log in before you can comment on or make changes to this bug.