Bug 1643450 - Python 2 is built against an old OpenSSL (1.0.1) while 1.1.1 is available in F29
Summary: Python 2 is built against an old OpenSSL (1.0.1) while 1.1.1 is available in F29
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python2
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1678207
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-26 09:49 UTC by Yaniv Kaul
Modified: 2019-03-29 19:10 UTC (History)
12 users (show)

Fixed In Version: python2-2.7.16-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 19:10:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Python 32947 None None None 2018-10-28 22:01:00 UTC
Ceph Project Bug Tracker 36425 None None None 2018-11-19 09:11:45 UTC

Description Yaniv Kaul 2018-10-26 09:49:23 UTC
Description of problem:
This, for example, prevents me from compiling Ceph on Fedora 29, as it identifies they are using different SSL versions.

Version-Release number of selected component (if applicable):
python2-2.7.15-11.fc29.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Try to compile Ceph (upstream, master) on F29 beta.


See https://tracker.ceph.com/issues/36425#change-123385 for initial report (on Ceph).

Comment 1 Miro Hrončok 2018-10-26 11:33:42 UTC
Python 2 doesn't support OpenSSL 1.1.1 (or at least it didn't when we made this change).

Python 2 support ends in 1 year + 2 months. Chances are it will never support OpenSSL 1.1.1. Christian Heimes might know more about the upstream plans there.

The preferred solution is to update Ceph to Python 3.

Comment 2 Miro Hrončok 2018-10-26 11:35:43 UTC
Note that Python 2 supports OpenSSL 1.1.0 and we only build it with 1.0.1 because openssl was updated from 1.1.0 to 1.1.1 without proper coordination.

Comment 3 Brad Hubbard 2018-11-19 06:00:03 UTC
Bumping severity on this as it is effecting multiple ceph developers.

Comment 4 Miro Hrončok 2018-11-19 08:37:04 UTC
I can keep the severity high, but this is not a high priority for us (sorry).

Use Python 3 for OpenSSL 1.1.1.


Christian, any news on legacy Python OpenSSL 1.1.1 compatibility?

Comment 8 Jason Dillaman 2018-11-19 19:51:56 UTC
Note: disabling python2 support in Ceph allows it to compile under F29: "cmake .. -DWITH_PYTHON2=OFF -DWITH_PYTHON3=ON -DMGR_PYTHON_VERSION=3"

Comment 10 Yaniv Kaul 2018-11-20 09:42:45 UTC
(In reply to Jason Dillaman from comment #8)
> Note: disabling python2 support in Ceph allows it to compile under F29:
> "cmake .. -DWITH_PYTHON2=OFF -DWITH_PYTHON3=ON -DMGR_PYTHON_VERSION=3"

It fails, with:
Scanning dependencies of target ec_isa
[  1%] Building C object src/erasure-code/isa/CMakeFiles/ec_isa.dir/__/__/isa-l/erasure_code/ec_base.c.o
In file included from /home/ykaul/github/ceph/src/include/types.h:19,
                 from /home/ykaul/github/ceph/src/isa-l/erasure_code/ec_base.c:34:
/home/ykaul/github/ceph/src/include/byteorder.h:5:10: fatal error: type_traits: No such file or directory
 #include <type_traits>
          ^~~~~~~~~~~~~
compilation terminated.


Seems to be something with the flags passed to gcc?

(And seems to be unrelated to THIS bug - should I open an upstream Ceph issue?)

Comment 11 Brad Hubbard 2018-11-20 10:13:16 UTC
(In reply to Yaniv Kaul from comment #10)
> (In reply to Jason Dillaman from comment #8)
> > Note: disabling python2 support in Ceph allows it to compile under F29:
> > "cmake .. -DWITH_PYTHON2=OFF -DWITH_PYTHON3=ON -DMGR_PYTHON_VERSION=3"
> 
> It fails, with:
> Scanning dependencies of target ec_isa
> [  1%] Building C object
> src/erasure-code/isa/CMakeFiles/ec_isa.dir/__/__/isa-l/erasure_code/ec_base.
> c.o
> In file included from /home/ykaul/github/ceph/src/include/types.h:19,
>                  from
> /home/ykaul/github/ceph/src/isa-l/erasure_code/ec_base.c:34:
> /home/ykaul/github/ceph/src/include/byteorder.h:5:10: fatal error:
> type_traits: No such file or directory
>  #include <type_traits>
>           ^~~~~~~~~~~~~
> compilation terminated.
> 
> 
> Seems to be something with the flags passed to gcc?
> 
> (And seems to be unrelated to THIS bug - should I open an upstream Ceph
> issue?)

Yes, please.

Comment 12 Yaniv Kaul 2018-11-20 10:25:46 UTC
(In reply to Brad Hubbard from comment #11)
> (In reply to Yaniv Kaul from comment #10)
> > (In reply to Jason Dillaman from comment #8)
> > > Note: disabling python2 support in Ceph allows it to compile under F29:
> > > "cmake .. -DWITH_PYTHON2=OFF -DWITH_PYTHON3=ON -DMGR_PYTHON_VERSION=3"
> > 
> > It fails, with:
> > Scanning dependencies of target ec_isa
> > [  1%] Building C object
> > src/erasure-code/isa/CMakeFiles/ec_isa.dir/__/__/isa-l/erasure_code/ec_base.
> > c.o
> > In file included from /home/ykaul/github/ceph/src/include/types.h:19,
> >                  from
> > /home/ykaul/github/ceph/src/isa-l/erasure_code/ec_base.c:34:
> > /home/ykaul/github/ceph/src/include/byteorder.h:5:10: fatal error:
> > type_traits: No such file or directory
> >  #include <type_traits>
> >           ^~~~~~~~~~~~~
> > compilation terminated.
> > 
> > 
> > Seems to be something with the flags passed to gcc?
> > 
> > (And seems to be unrelated to THIS bug - should I open an upstream Ceph
> > issue?)
> 
> Yes, please.

https://tracker.ceph.com/issues/37336

Comment 13 Petr Viktorin 2019-01-07 14:00:49 UTC
This is currently blocked on Christian, who promised to help with Python 2's OpenSSL compatibility upstream. Unfortunately, the python-maint team can't deal with SSL issues effectively.

Comment 14 Miro Hrončok 2019-03-01 14:12:37 UTC
2.7.16 has this. We are building rc1 in rawhide and will update it down to at least F29 after the final version is released.

Comment 15 Fedora Update System 2019-03-05 11:24:58 UTC
python2-2.7.16-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c91ce7b3c

Comment 16 Fedora Update System 2019-03-06 22:17:30 UTC
python2-2.7.16-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c91ce7b3c

Comment 17 Fedora Update System 2019-03-06 22:53:39 UTC
python2-2.7.16-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c91ce7b3c

Comment 18 Fedora Update System 2019-03-11 14:18:02 UTC
python2-2.7.16-1.fc30 python2-docs-2.7.16-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c91ce7b3c

Comment 19 Fedora Update System 2019-03-11 14:41:37 UTC
python2-2.7.16-1.fc30, python2-docs-2.7.16-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c91ce7b3c

Comment 20 Fedora Update System 2019-03-29 19:10:02 UTC
python2-2.7.16-1.fc30, python2-docs-2.7.16-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.