Bug 164360 - During formating of partitions anaconda reports bug if you rename a Logical Volume during setup
During formating of partitions anaconda reports bug if you rename a Logical V...
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 04:30 EDT by Matt Perry
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 10:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Perry 2005-07-27 04:30:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
When setting up a new Fedora Core 4 system, if you use LVM and try to rename a Logical Volume to say "LogVolRoot" instead of using "LogVol00" (then continue through all the other prompts) and get to "About to Install", click Next. You get exception occurred.  An unhandled exception has occured...

Traceback (most recent call list)
File "/usr/lib/anaconda/gui.py" line 1137...
...
File "/usr/lib/anaconda/packages.py" line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py" line 726, in savePartitions
disk.commit
error: Error: Error informing the kernel about modifications to partition /dev/hda5 - Device or resource busy.  This means that Linux won't know about any changes made to /dev/hda5 until you reboot...

Now, this appears to only happen if you have at least 2 Logical Volume partitions.  In this case, one was called LogVolRoot and the other LogVolHome

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 using anaconda
2. During LVM setup, rename at least 2 LVMs to say "LogVolRoot" instead of LogVol00 and "LogVolHome" instead of LogVol01
3. Continue through the setup
4. When it gets to last screan, click Next to begin formatting partitions, error occurs.
  

Actual Results:  get the error report stated above

Expected Results:  format partions, and install OS.  (which happens if everyone is done the same but leave the Logical Volumes names as the default.  (ie, LogVol00)

Additional info:
Comment 1 Jeremy Katz 2005-07-27 10:24:53 EDT

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.