Bug 1643929 - geo-rep: gluster-mountbroker status crashes
Summary: geo-rep: gluster-mountbroker status crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1644515 1644516
TreeView+ depends on / blocked
 
Reported: 2018-10-29 13:17 UTC by Kotresh HR
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1644515 1644516 (view as bug list)
Environment:
Last Closed: 2018-11-28 04:44:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21507 0 None Merged geo-rep/scripts: Fix traceback in gluster-mountbroker 2018-10-30 13:13:45 UTC

Description Kotresh HR 2018-10-29 13:17:30 UTC
Description of problem:
gluster-mountbroker status crashes with traceback 
'str object has not attribute get'


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Not always. Observed when node was in bad state.



Actual results:
gluster-mountbroker status command crashed

Expected results:
gluster-mountbroker status should not crash

Additional info:

Comment 1 Worker Ant 2018-10-29 13:19:57 UTC
REVIEW: https://review.gluster.org/21507 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-10-30 13:13:43 UTC
REVIEW: https://review.gluster.org/21507 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#2) for review on master by Amar Tumballi

Comment 3 Kotresh HR 2018-11-28 04:44:06 UTC
Fixed in v5.1

Comment 4 Shyamsundar 2018-11-29 15:26:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.6, please open a new bug report.

glusterfs-4.1.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-November/000116.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Shyamsundar 2019-03-25 16:31:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.