Bug 1644516 - geo-rep: gluster-mountbroker status crashes
Summary: geo-rep: gluster-mountbroker status crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1643929
Blocks: 1644515
TreeView+ depends on / blocked
 
Reported: 2018-10-31 04:25 UTC by Kotresh HR
Modified: 2018-11-29 15:26 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1643929
Environment:
Last Closed: 2018-11-28 06:16:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21507 0 None None None 2018-10-31 04:25:46 UTC
Gluster.org Gerrit 21518 0 None Merged geo-rep/scripts: Fix traceback in gluster-mountbroker 2018-11-05 20:37:57 UTC

Description Kotresh HR 2018-10-31 04:25:47 UTC
+++ This bug was initially created as a clone of Bug #1643929 +++

Description of problem:
gluster-mountbroker status crashes with traceback 
'str object has not attribute get'


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Not always. Observed when node was in bad state.



Actual results:
gluster-mountbroker status command crashed

Expected results:
gluster-mountbroker status should not crash

Additional info:

--- Additional comment from Worker Ant on 2018-10-29 09:19:57 EDT ---

REVIEW: https://review.gluster.org/21507 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#1) for review on master by Kotresh HR

--- Additional comment from Worker Ant on 2018-10-30 09:13:43 EDT ---

REVIEW: https://review.gluster.org/21507 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#2) for review on master by Amar Tumballi

Comment 1 Worker Ant 2018-10-31 04:28:14 UTC
REVIEW: https://review.gluster.org/21518 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#1) for review on release-4.1 by Kotresh HR

Comment 2 Worker Ant 2018-11-05 20:37:55 UTC
REVIEW: https://review.gluster.org/21518 (geo-rep/scripts: Fix traceback in gluster-mountbroker) posted (#2) for review on release-4.1 by Shyamsundar Ranganathan

Comment 3 Kotresh HR 2018-11-28 06:16:04 UTC
Fixed in 4.1.6

Comment 4 Shyamsundar 2018-11-29 15:26:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.6, please open a new bug report.

glusterfs-4.1.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-November/000116.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.