Bug 1644129 - Excessive logging in posix_update_utime_in_mdata
Summary: Excessive logging in posix_update_utime_in_mdata
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ctime
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1644524 1644526
TreeView+ depends on / blocked
 
Reported: 2018-10-30 05:24 UTC by Kotresh HR
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1644524 1644526 (view as bug list)
Environment:
Last Closed: 2018-11-28 06:06:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21520 0 None Merged posix/ctime: Avoid log flood in posix_update_utime_in_mdata 2018-11-02 01:05:58 UTC

Description Kotresh HR 2018-10-30 05:24:38 UTC
Description of problem:
posix_update_utime_in_mdata  logs an error even when consistent ctime is not enabled. This causes a flood of log messages, like:

[2018-09-28 12:44:26.636267] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Invalid argument]
[2018-09-28 12:44:31.564728] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file
[2018-09-28 12:44:47.156757] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Function not implemented]
The message "W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Invalid argument]" repeated 52 times 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-10-31 05:07:38 UTC
REVIEW: https://review.gluster.org/21520 (posix/ctime: Avoid log flood in posix_update_utime_in_mdata) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-11-02 01:05:56 UTC
REVIEW: https://review.gluster.org/21520 (posix/ctime: Avoid log flood in posix_update_utime_in_mdata) posted (#2) for review on master by Amar Tumballi

Comment 3 Kotresh HR 2018-11-28 06:06:06 UTC
Fixed in v5.1

Comment 4 Shyamsundar 2019-03-25 16:31:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.