Bug 1644526 - Excessive logging in posix_update_utime_in_mdata
Summary: Excessive logging in posix_update_utime_in_mdata
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ctime
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1644129
Blocks: 1644524
TreeView+ depends on / blocked
 
Reported: 2018-10-31 05:16 UTC by Kotresh HR
Modified: 2018-11-29 15:20 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1644129
Environment:
Last Closed: 2018-11-28 05:58:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21520 0 None None None 2018-10-31 05:16:35 UTC
Gluster.org Gerrit 21522 0 None Merged posix/ctime: Avoid log flood in posix_update_utime_in_mdata 2018-11-08 14:36:27 UTC

Description Kotresh HR 2018-10-31 05:16:36 UTC
+++ This bug was initially created as a clone of Bug #1644129 +++

Description of problem:
posix_update_utime_in_mdata  logs an error even when consistent ctime is not enabled. This causes a flood of log messages, like:

[2018-09-28 12:44:26.636267] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Invalid argument]
[2018-09-28 12:44:31.564728] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file
[2018-09-28 12:44:47.156757] W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Function not implemented]
The message "W [MSGID: 113117] [posix-metadata.c:569:posix_update_utime_in_mdata] 0-dyn_cfu-posix: posix utime set mdata failed on file [Invalid argument]" repeated 52 times 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-10-31 01:07:38 EDT ---

REVIEW: https://review.gluster.org/21520 (posix/ctime: Avoid log flood in posix_update_utime_in_mdata) posted (#1) for review on master by Kotresh HR

Comment 1 Worker Ant 2018-10-31 05:19:28 UTC
REVIEW: https://review.gluster.org/21522 (posix/ctime: Avoid log flood in posix_update_utime_in_mdata) posted (#1) for review on release-5 by Kotresh HR

Comment 2 Worker Ant 2018-11-08 14:36:25 UTC
REVIEW: https://review.gluster.org/21522 (posix/ctime: Avoid log flood in posix_update_utime_in_mdata) posted (#2) for review on release-5 by Shyamsundar Ranganathan

Comment 3 Kotresh HR 2018-11-28 05:58:47 UTC
Fixed in v5.1

Comment 4 Shyamsundar 2018-11-29 15:20:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.1, please open a new bug report.

glusterfs-5.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-November/000116.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.