Bug 1644500 - Can't upgrade due to libxfconf-0.so.2 requirement
Summary: Can't upgrade due to libxfconf-0.so.2 requirement
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-31 02:57 UTC by Ciaran Wills
Modified: 2019-03-28 16:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 07:50:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Ciaran Wills 2018-10-31 02:57:31 UTC
Description of problem:
Upgrade from Fedora 28 to 29 can't proceed.  Looks like a XFCE dependency?

Error: 
 Problem: package imsettings-xfce-1.7.3-5.fc29.x86_64 requires libxfconf-0.so.2()(64bit), but none of the providers can be installed
  - problem with installed package imsettings-xfce-1.7.3-3.fc28.x86_64
  - xfconf-4.12.1-6.fc28.x86_64 does not belong to a distupgrade repository
  - imsettings-xfce-1.7.3-3.fc28.x86_64 does not belong to a distupgrade repository

Related? - https://bugzilla.redhat.com/show_bug.cgi?id=1640781

Version-Release number of selected component (if applicable):


How reproducible:
Follow instructions to upgrade from 28 to 29 with DNF with XFCE installed.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kamil Páral 2018-10-31 10:36:41 UTC
This will be fixed once the mirrors sync:
https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cbafd365e


Note You need to log in before you can comment on or make changes to this bug.