This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 164502 - by default php-mysql binding is not installed, causing php-mysql statements to fail
by default php-mysql binding is not installed, causing php-mysql statements t...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
:
: 164503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:24 EDT by Justin Wiley
Modified: 2013-01-09 20:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 17:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Wiley 2005-07-28 08:24:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

Description of problem:
php-mysql object libraries are not installed by default when performing a standard server or custom installation of Fedora (any version I believe).  As a result, someone attempting to create a standard LAMP server will see an error when using PHP scripts with functions such as "mysql_connect".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Begin Fedora installation
2.Select Server type
3.Specify specific packages and choose MySQL database
4.Install
  

Actual Results:  I have a LAMP server where P does not speak to M.  I have to be wise enough to interpret the error message coming back from PHP, and then manually install the RPM with the correct RPM

Expected Results:  Whenever MySQL and Apache and PHP are all selected, the php-mysql library should be on by default. And probably php-postgres, php-odbc, probably all because they are small in size and offer virtually no performance hit to either server.

Additional info:

This detracts from the "plug and play" nature of Fedora.  Everything generally works great out of the box, its frustrating that creating a generic LAMP server should not work when immediatly when things like SELinux work great with no modifications.
Comment 1 Joe Orton 2005-07-28 08:27:10 EDT
*** Bug 164503 has been marked as a duplicate of this bug. ***
Comment 2 Justin Wiley 2005-09-05 23:41:03 EDT
A walkthrough on how to fix the problem if you happen to install without the
right libraries.

Note this only applies to Fedora Core 4, although it would probably work with
FC3 as well with different file names (as FC3 uses mysql 3.21 and php 4.3).

1. Check to make sure its not already installed (must be root)
su
rpm -qa | grep php-mysql

2. Pop FC4 disk 1 in and mount your cdrom (if necessary)
mount -tauto /dev/cdrom /media/cdrom

3. Install the file
rpm -Uvh /media/cdrom/Fedora/RPMS/php-mysql-5.0.4-10.i386.rpm

4. Start/restart apache and mysql
/sbin/service httpd restart
/sbin/service mysqld restart
Comment 3 Jesse Keating 2006-04-11 17:49:56 EDT
Currently there is no way to do conditional requires, such that if group A is
selected, and group B is selected, make sure package C is also selected.  Each
group is considered stand alone, and people that want a Webserver may not want
mysql, and people that want mysql may not want php.  Likewise we can't rely on
package deps for this as people that want php may not want mysql along with it.
 So unfortunately there is no good way of resolving this issue as things
currently stand.

Note You need to log in before you can comment on or make changes to this bug.