Bug 164503 - by default php-mysql binding is not installed, causing php-mysql statements to fail
by default php-mysql binding is not installed, causing php-mysql statements t...
Status: CLOSED DUPLICATE of bug 164502
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:24 EDT by Justin Wiley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 08:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Wiley 2005-07-28 08:24:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

Description of problem:
php-mysql object libraries are not installed by default when performing a standard server or custom installation of Fedora (any version I believe).  As a result, someone attempting to create a standard LAMP server will see an error when using PHP scripts with functions such as "mysql_connect".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Begin Fedora installation
2.Select Server type
3.Specify specific packages and choose MySQL database
4.Install
  

Actual Results:  I have a LAMP server where P does not speak to M.  I have to be wise enough to interpret the error message coming back from PHP, and then manually install the RPM with the correct RPM

Expected Results:  Whenever MySQL and Apache and PHP are all selected, the php-mysql library should be on by default. And probably php-postgres, php-odbc, probably all because they are small in size and offer virtually no performance hit to either server.

Additional info:

This detracts from the "plug and play" nature of Fedora.  Everything generally works great out of the box, its frustrating that creating a generic LAMP server should not work when immediatly when things like SELinux work great with no modifications.
Comment 1 Joe Orton 2005-07-28 08:26:58 EDT

*** This bug has been marked as a duplicate of 164502 ***

Note You need to log in before you can comment on or make changes to this bug.