Bug 164585 - lvm does not allow for a mirror on less then 3 pvs
lvm does not allow for a mirror on less then 3 pvs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
: FutureFeature, OtherQA
: 180442 205829 (view as bug list)
Depends On:
Blocks: 176344 188953 200229 232471 232479 253037 367631
  Show dependency treegraph
 
Reported: 2005-07-28 18:07 EDT by Corey Marthaler
Modified: 2010-10-21 23:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 22:47:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-07-28 18:07:14 EDT
Description of problem:
The help says that with '--alloc anywhere' I should be allowed to have a 1 or 2
PV mirror, but that appears to not be the case:

Two PV case:
[root@link-11 ~]# pvscan
  PV /dev/sdc1   VG VG_2   lvm2 [517.64 GB / 517.64 GB free]
  PV /dev/sdd1   VG VG_2   lvm2 [517.64 GB / 517.64 GB free]
  PV /dev/sda1   VG VG_1   lvm2 [517.65 GB / 517.65 GB free]
  PV /dev/sdb1   VG VG_1   lvm2 [517.64 GB / 517.64 GB free]
  Total: 4 [2.02 TB] / in use: 4 [2.02 TB] / in no VG: 0 [0   ]
[root@link-11 ~]# vgscan
  Reading all physical volumes.  This may take a while...
  Found volume group "VG_2" using metadata type lvm2
  Found volume group "VG_1" using metadata type lvm2
[root@link-11 ~]# lvcreate -m 1 -L 400G VG_1 -n mirror1 --alloc anywhere
  Insufficient suitable allocatable extents for logical volume : 204800 more
required
[root@link-11 ~]# lvcreate -m 1 -L 40G VG_1 -n mirror1 --alloc anywhere
  Insufficient suitable allocatable extents for logical volume : 20480 more required
[root@link-11 ~]# lvcreate -m 1 -L 4G VG_1 -n mirror1 --alloc anywhere
  Insufficient suitable allocatable extents for logical volume : 2048 more required


One PV case:
[root@link-11 ~]# vgcreate VG /dev/sda1
  Volume group "VG" successfully created
[root@link-11 ~]# lvcreate -m 1 -n mirror1 --alloc anywhere -L 4G VG
  Insufficient suitable allocatable extents for logical volume : 2048 more required


Three PV case:
[root@link-11 ~]# vgcreate VG /dev/sda1 /dev/sdb1 /dev/sdc1
  Volume group "VG" successfully created
[root@link-11 ~]# lvcreate -m 1 -n mirror1 --alloc anywhere -L 4G VG
  Logical volume "mirror1" created
[root@link-11 ~]# lvscan
  ACTIVE            '/dev/VG/mirror1' [4.00 GB] anywhere
  ACTIVE            '/dev/VG/mirror1_mlog' [4.00 MB] anywhere
  ACTIVE            '/dev/VG/mirror1_mimage_0' [4.00 GB] inherit
  ACTIVE            '/dev/VG/mirror1_mimage_1' [4.00 GB] inherit


Version-Release number of selected component (if applicable):
[root@link-11 ~]# rpm -qa | grep lvm2
lvm2-2.01.13-1.0.RHEL4
lvm2-cluster-2.01.09-4.0.RHEL4


How reproducible:
everytime
Comment 1 Alasdair Kergon 2005-08-08 15:53:59 EDT
That functionality hasn't been implemented yet.
Comment 2 Alasdair Kergon 2005-08-08 15:55:05 EDT
(low priority because, for performance reasons, it is not a sensible configuration)
Comment 3 Alasdair Kergon 2006-03-15 10:40:11 EST
*** Bug 180442 has been marked as a duplicate of this bug. ***
Comment 6 Larry Troan 2006-07-20 18:35:58 EDT
Moving for consideration to RHEL4.5.
Comment 7 Larry Troan 2006-07-20 18:37:28 EDT
Moving for consideration to RHEL4.5.
Comment 9 Corey Marthaler 2006-09-11 17:50:22 EDT
*** Bug 205829 has been marked as a duplicate of this bug. ***
Comment 11 Jun'ichi NOMURA 2006-11-30 11:51:48 EST
Another set of patches in lvm-devel:
https://www.redhat.com/archives/lvm-devel/2006-October/msg00030.html
Comment 12 Dave Wysochanski 2006-12-20 23:55:39 EST
What is the status of the above patches?
Comment 13 Jun'ichi NOMURA 2006-12-21 12:07:50 EST
Re: comment#12

Dave,
They're not accepted in upstream.
Comment 14 Jun'ichi NOMURA 2007-01-08 14:11:35 EST
Patch set proposed for BZ#204127 should fix this problem too.
Comment 15 Jonathan Earl Brassow 2007-01-08 15:06:46 EST
I've tested with the patches for BZ#204127 and found them to fix this bug.
Comment 20 Larry Troan 2007-03-01 18:24:21 EST
Bug was closed because it didn't make 4.5. Alasdair Kergon opened it again
stating we plan to do it in 4.6.
Comment 23 RHEL Product and Program Management 2007-03-09 20:14:55 EST
This bugzilla had previously been approved for engineering
consideration but Red Hat Product Management is currently reevaluating
this issue for inclusion in RHEL4.6.
Comment 32 RHEL Product and Program Management 2008-05-28 23:04:01 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 34 Larry Troan 2008-06-13 09:31:56 EDT
Missed RHEL4.7 and dies not meet the criteria of 4.8 (hardware enablement).
Likely to be closed as WONTFIX for RHEL4.

Note You need to log in before you can comment on or make changes to this bug.