Bug 164602 - GhostScript renders Courier font with incorrect width
GhostScript renders Courier font with incorrect width
Status: CLOSED DUPLICATE of bug 149756
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: urw-fonts (Show other bugs)
4.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 01:58 EDT by George Hansper
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 07:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Hansper 2005-07-29 01:58:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804

Description of problem:
Text rended using a Courier font in ghostscript appear too wide 
on the page, and are truncated.

The root cause is unclear, but replacing the package urw-fonts with the current release from Fedora Core 4 (urw-fonts-2.3-1.noarch.rpm) resolves the problem.

Mandriva 2005 LE uses urw-fonts-2.0-15mdk and this gives results consistant with both Fedora Core 4 and Red Hat 6.2 (urw-fonts-2.0-4).



Version-Release number of selected component (if applicable):
urw-fonts-2.2-6

How reproducible:
Always

Steps to Reproduce:
1. ( echo This is a test of the Courier11 font\\n123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 \\n---------------------------------------------------------------------------------------------------\\n\\n\\n\\n123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 \\n--------------------------------------------------------------------------------------------------- ) | enscript -b"Courier Font (urw-fonts) test page" -o tmp.ps -fCourier11 -G -c
2. gs -sDEVICE=x11 tmp.ps

  

Actual Results:  The text runs off the right-hand edge of the page.


Expected Results:  Normally, the lines are clipped at a point which lines up (roughly) with the 
right-hand edge of the graphical header.

Additional info:
Comment 1 Ngo Than 2005-07-29 07:29:31 EDT

*** This bug has been marked as a duplicate of 149756 ***

Note You need to log in before you can comment on or make changes to this bug.