Bug 149756 - \tt (or \ttfamily) not recognized
\tt (or \ttfamily) not recognized
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: urw-fonts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
: 153712 164239 164602 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-02-25 17:15 EST by dina
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2005-409
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file containing .tex file and .cls file that have problem with \tt (53.72 KB, application/zip)
2005-03-30 08:54 EST, dina
no flags Details
file containing .dvi file and .pdf file that have problem with \tt (2.51 KB, application/zip)
2005-03-30 10:20 EST, dina
no flags Details
sample files using prosper (93.17 KB, application/zip)
2005-04-06 16:30 EDT, dina
no flags Details
Screenshot of prosper.pdf file viewed by various xpdf versions (120.00 KB, application/x-tar)
2005-04-08 03:56 EDT, Jindrich Novy
no flags Details

  None (edit)
Description dina 2005-02-25 17:15:07 EST
Description of problem:

the \tt (or \ttfamily) is not recognized in LaTex under RH-EL4. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce: 
This is the tex example:

\documentclass[a4paper,10pt]{article}

\usepackage{amsmath}
\usepackage{latexsym}
\usepackage{epsfig}
\usepackage{amsfonts,amssymb}

\begin{document}
{\tt \{lukas, peter\}@unitex.com}\\
\tt{something to write using tt}
\end{document}

  
Actual results:
the size and space between letters do not look proportional
(sometimes to close, sometimes to distance to each other)
especially when tex containing curly bracket (\{ \})

Additional info:
Warning message when compiling the tex file to dvi:
./test.tex:0:No file OMScmtt.fd. on input line 10.
./test.tex:10: Font shape `OMS/cmtt/m/n' undefined(Font) using
`OMS/cmsy/m/n' instead(Font) for symbol `textbraceleft' on input line
10. Font shape `OMS/cmtt/m/n' undefined(Font) using `OMS/cmsy/m/n'
instead(Font) for symbol `textbraceleft'
./test.tex:0: Some font shapes were not available, defaults substituted.
Comment 3 Jindrich Novy 2005-03-01 03:46:23 EST
Please note that in the line "\tt{something to write using tt}" you set the 
\tt globally what wasn't intentional I think. It's always a good idea to 
define such properties to be valid only for a specified block what is done at 
line "{\tt \{lukas, peter\}@unitex.com}" for instance.

The problem with the inproportional spaces between letters is caused by the 
font substitution from the proportional cmtt to not proportional cmsy font 
shape. The same warning message I reproduced successfully on my RHEL4 box. To 
be sure that you see the same thing as me, could you please attach here the 
final DVI or PDF file?
Comment 4 dina 2005-03-30 08:54:01 EST
Created attachment 112449 [details]
file containing .tex file and .cls file that have problem with \tt
Comment 5 dina 2005-03-30 09:05:59 EST
I think you see the same warning as what I see. This warning appear if for
example we use article style file, but although there is warning, the font
substitution works fine.
I looked at the file where I have problem with the font substitution, and
actually this happens when I used the IEEE conference style file (ieeeconf.cls).
The DVI output seems fine, but the problem can be seen on the PDF output. I have
attached the file example where the problem occur. Please try to compile it and
see the difference between the DVI output and the PDF output of this file.
I think the problem can be solved by editing some lines on the .cls file, but I
do not expect to have to do this hassle just because I move to EL4 (the problem
did not exist before)...
Comment 6 dina 2005-03-30 10:20:35 EST
Created attachment 112457 [details]
file containing .dvi file and .pdf file that have problem with \tt 

Adding my previous attachment, here I also attach the .dvi output and .pdf
output of the file test.tex with style file ieeeconf.cls compiled with LaTeX on
EL4.
Comment 7 Jindrich Novy 2005-03-31 13:58:26 EST
Have you tried to remove the \renewcommand{\ttdefault}{pcr} line from ieeeconf.cls ?
Comment 8 dina 2005-04-01 14:57:13 EST
Yes, I tried it. It fixes the problem of the .pdf output although now the
warning message about the symbol `textbraceleft' and `textbraceright' appears.
We can get rid of the warning message by typing the curly bracket outside the
\tt block (although it does not look eficient), for example
\{{\tt lukas, peter}\}{\tt @unitex.com}
instead of
{\tt \{lukas, peter\}@unitex.com}
and
{\small \{{\tt lukas, peter}\}{\tt @unitex.com}
instead of
{\tt\small \{lukas, peter\}@unitex.com}

I think the problem is solved now, thanks!
However, I was wondering why the symbols \{ and \} are not recognized by cmsy
fonts? Could there be other symbol that are not recognized? Why RHEL4 does not
retain the cmtt fonts that are already working fine in the erlier version?
Comment 9 Suzanne Hillman 2005-04-05 13:53:16 EDT
Closing as NOTABUG, based on comment #8.
Comment 10 dina 2005-04-05 14:23:04 EDT
I am still not happy with the solution... 
I rewrite again here my complaint:
However, I was wondering why the symbols \{ and \} are not recognized by cmsy
fonts? Could there be other symbols that are not recognized? Why RHEL4 does not
retain the cmtt fonts that are already working fine in the erlier version?
Comment 11 EE CAP Admin 2005-04-06 08:01:20 EDT
I am also seeing this using some prosper templates for presentations.

Things I compiled on EL3 fine in LaTeX are having trouble in EL4.  In particular
writing email addresses using prosper...

{\fontsize{7}{7}\selectfont\texttt{\@email}}

seems to be selecting the font in the prosper class file.

Do we have an ETA for a fix, or do I need to dig out an EL3 machine; I have a
conference presentation to prepare for the end of the week.

Paul
Comment 12 Jindrich Novy 2005-04-06 09:42:18 EDT
dina: I'm investigating what's bad with the font substitution.

EE: Could you please attach here a complete sample source using
beamerprosper.sty to let me investigate what actually goes wrong?
Comment 13 dina 2005-04-06 16:30:32 EDT
Created attachment 112778 [details]
sample files using prosper

I attach the sample .tex file where I use proper. I also include the .pdf
output of it. I agree with Paul that the trouble with the font substitution is
even more severe here... :(
Comment 14 EE CAP Admin 2005-04-06 16:40:15 EDT
Hi Jindrich,

Just to comfirm - I see exactly the same behaviour as Dina.  The letters are too
close together in the tt font, and there is sometimes bizarre random spacing of
characters... look at the email addresses in the PDF file Dina has attached - I
see that strange behaviour too.

Cheers,

Paul
Comment 15 Jindrich Novy 2005-04-08 03:51:31 EDT
Hmmm, I see we haven't included prosper class in RHEL4 teTeX, did you install
prosper manually?

wrt comment #13: I can see the invalid spacing of the \tt font when viewed by
the latest version of xpdf (3.00), it's displayed differently by xpdf-2.02 and
finally the pdf is displayed fine with xpdf-0.92. Looks like xpdf has something
to do with this.

Than, do you have any hint for this? Please note I used the same pdf for all the
xpdf versions.
Comment 16 Jindrich Novy 2005-04-08 03:56:37 EDT
Created attachment 112848 [details]
Screenshot of prosper.pdf file viewed by various xpdf versions

I'm attaching the screenshot to show you what I actually see with different
xpdf versions.
Comment 17 EE CAP Admin 2005-04-08 06:06:19 EDT
Guys - note that the pdf is also wrongly displayed in acroread 5 - but yes - it
looks ok in zpdf-0.92.  Very odd!  Not tried it in the beta of acroread 7...

As for the prosper install - right - it's not included in RHEL by default, but
it just requires a prosper class file and .sty file... which I normally dump in
the document working directory rather than the system latex directory - for ease
of portability of the document.  I guess Dina has done something similar?

If you would consider including prosper that would be a good thing... for me at
least.

Cheers,

Paul
Comment 18 John W. Lockhart 2005-04-08 11:04:44 EDT
Is it possible that the onscreen display of courier is being 
affected by bug 140584 as well?
Comment 19 Jindrich Novy 2005-04-09 02:54:56 EDT
*** Bug 153712 has been marked as a duplicate of this bug. ***
Comment 20 Jindrich Novy 2005-04-09 03:03:02 EDT
John, it's possible, yes. But it's just a guess at the moment. I think it's good
to wait for Than's opition here. I'll investigate this case more on monday.
Comment 21 Jindrich Novy 2005-04-11 04:06:53 EDT
Ok, upgrading to urw-fonts-2.3-1 solved the bad typesetting of courier fonts for me.

Than, could you please release an erratum for urw-fonts?
Comment 22 Ngo Than 2005-04-11 04:20:26 EDT
i think it's to late for RHEL4-U1, but it's fine with me to have it in comming
RHEL4-U2. Floian, could you please add it U2? thanks
Comment 23 EE CAP Admin 2005-04-11 04:53:50 EDT
Guys,

I appreciate that you have release and quality procedures but waiting another
6months for this to be fixed in U2 is not what I had in mind.  Please can you
just issue an errata *much* sooner?  It's quite serious bug for LaTeX users and
surely fixing bugs in a font package is a pretty benign thing?  

It's a pain for me and my colleagues - we upgraded all but one of our machines
to EL4 and it's annoying to have to ssh into another box just to compile a latex
document.

Please push this out as fast as you are able.

Thanks,

Paul
Comment 24 Ryan Szypowski 2005-04-11 13:57:50 EDT
Will the fix make it into Fedora Core 4?  This bug occurs in FC3 as well...
Comment 25 Ngo Than 2005-04-11 16:19:52 EDT
It's already in fc4test2! i will do urw-fonts update for fc3 this week
Comment 30 EE CAP Admin 2005-06-18 15:32:24 EDT
Let's review the progress of this bug:

Reported by dslaila on 25th Feb.
Fixed in Fedora 11th April.
Still not fixed in EL4 on 18th June. (possibly - although not confirmed - it
might appear in another 3months in U2)

So as I see it those of us who are paying for support with EL4 licenses have to
keep waiting for a fixz that may never happen, whilst those using free Fedora
already have this fixed.

Forgive me for thinking that your support model is upside down and completely
acceptable.  I must be missing something.  

I am again in need for these fonts to work properly so I can prepare a
presentation and I am alarmed that it still has not been fixed.

I'd like to ask redhat the question of whether they think this is acceptable.  6
months to not release a fix for a font bug...

And yes - I could - and I now will - find an rpm which fixes it for me from
Fedora, if one exists that doesn't get me into dependency hell.  It just all
rather undermines the point of paying for a linux distribution when it seems the
free ones are better.

I wrote an email to David Lawrence (he is down as the QA contact on this bug)
and got no response.

Please do not tell me that I should be using my paid for support channel to get
this fixed.  The pace they have been moving at putting in features like ACLs on
nfs 3 (which are not present in EL4 dispite them being in EL3 and the release
notes of EL4 saying they are supported) means that to be honest it's simply not
worth the effort reporting stuff anymore.

Paul
Comment 33 Jindrich Novy 2005-07-27 03:41:42 EDT
*** Bug 164239 has been marked as a duplicate of this bug. ***
Comment 34 Ngo Than 2005-07-29 07:29:38 EDT
*** Bug 164602 has been marked as a duplicate of this bug. ***
Comment 35 Red Hat Bugzilla 2005-10-05 09:34:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-409.html

Note You need to log in before you can comment on or make changes to this bug.