Bug 164603 - audit update breaks hwclock
audit update breaks hwclock
Status: CLOSED DUPLICATE of bug 164486
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 02:20 EDT by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 06:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2005-07-29 02:20:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
After updating audit to 0.9.19-2.FC4 I get an error after udev is started that says that it can't connot to the audit system.
I found this in the audit logs:

> type=AVC msg=audit(1122549673.001:7418105): avc:  denied  { create } for  pid=34 19 comm="hwclock" scontext=root:system_r:hwclock_t tcontext=root:system_r:hwcloc k_t tclass=netlink_audit_socket
> type=SYSCALL msg=audit(1122549673.001:7418105): arch=c000003e syscall=41 success =no exit=-13 a0=10 a1=3 a2=9 a3=42e8bfa9 items=0 pid=3419 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="hwclock" exe="/sbin/hwclock"


this results in an incorrect clock (+2h)
I am not using ntpd.
Timezonesettings are correct and it worked fine before the update.
I also found this in dmesg:
audit: initializing netlink socket (disabled)
Why is it disabled? hwclock trys to connect to it.



Version-Release number of selected component (if applicable):
audit-0.9.19-2.FC4;audit-libs-0.9.19-2.FC4

How reproducible:
Always

Steps to Reproduce:
1. boot
2. look at the clock 
3. see that the clock is +2h 
  

Actual Results:  Clock is incorrect

Expected Results:  Clock should be correct

Additional info:
Comment 1 drago01 2005-07-29 02:43:20 EDT
updating to selinux-policy-targeted from updates testing fixes this problem.
Comment 2 Steve Grubb 2005-07-29 06:45:00 EDT
This is s duplicate of #164486. Closing.

*** This bug has been marked as a duplicate of 164486 ***

Note You need to log in before you can comment on or make changes to this bug.