Bug 164615 - prelink breaks ld.so
Summary: prelink breaks ld.so
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 166033 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-29 11:32 UTC by David Woodhouse
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.3.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 14:51:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2005-07-29 11:32:21 UTC
After prelinking, ld.so no longer starts up at all.

Starting program: /lib/ld-2.3.90.so
Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
You can't do that without a process to debug.

Comment 1 Jakub Jelinek 2005-07-29 14:51:50 UTC
For details see http://sources.redhat.com/ml/binutils/2005-07/msg00502.html
For now, prelink just looks for the expected 4 consecutive words at
the start of .got, at the end and around offset 32768.

Comment 2 David Woodhouse 2005-08-27 09:14:29 UTC
*** Bug 166033 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.