Bug 166033 - Freezes after booting at "Freeing unused kernel memory"
Freezes after booting at "Freeing unused kernel memory"
Status: CLOSED DUPLICATE of bug 164615
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 20:37 EDT by John Eckerdal
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-27 05:14:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckerdal 2005-08-15 20:37:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b) Gecko/20050125 Firefox/1.0+

Description of problem:
This problem has happened to me twice.

First time:

1. I was compiling the 2.6.12.4 kernel (still running the stock FC4 kernel).
2. Compiled finished and I was about to type make modules_install
3. This caused "segmentation fault" to be displayed.
4. I tried dmesg -> "segmentation fault"
5. I tried shutdown -h now -> "segmentation fault"
6. I tried several other commands. Same result. Not even possible to exit the shell cleanly.
7. I manually shut down the machine.
8. After power up Linux boots normally until it reaches the point of "Freeing unused kernel memory" where after printing this it freezes.
9. I boot to Mac OS X where everything is fine. No problems visible.

This time I was logged in as root.

Second time:

1. This time I managed to compile a 2.6.12.4 kernel and was running this.
The compiler I used was the stock GCC compiler that came with FC4 (4.0.1-7
maybe).
2. I extracted a CVS snapshot of X.org to try to see if this helps the problem with radeon not finding any screens (X is not possible to use).
3. I started the normal make World. However I interrupted the compile and shut the computer down.
4. When returning I started the machine again and let the compilation continue.
5. It finished without errors. 
6. I tried to enter a command (to install). This caused "segmentation fault".
7. I tried several other commands with the same result.
8. I manually shut down the computer and rebooted it.
9. After power up Linux boots normally until it reaches the point of "Freeing unused kernel memory" where after printing this it freezes.
10. I boot to Mac OS X where everything is fine. No problems visible.
11. I tried to let the computer "wait awhile" but same result when booting.

In both cases I booted into resuce mode on the CD and ran e2fck on the disk
and this returned without problems.

However upon trying to chroot /mnt/sysimage I always get "segmentation fault"
so I have not been able to verify the integrity of the RPM database.

It is possible to mount the partition and view all the files on it and the
ones I looked at seems okayish but it is hard to tell.



Version-Release number of selected component (if applicable):
Fedora Core 4 kernel, 2.6.12.4 kernel

How reproducible:
Sometimes

Steps to Reproduce:
1. Compile something large
2. Every command entered in prompt causes segmentation fault
3. Reboot
4. Freeze at "Freeing unused memory".
  

Actual Results:  1. There are segmentation faults for every command run at step two.
Not even possible to do a shutdown -h now

2. Freeze at "Freeing unused memory".

Expected Results:  1. No segmentation fault for every command run at step two.

2. No Freeze att "Freeing unused memory".

Additional info:

I have a Mac Mini 1.2 GHz with 512 MB RAM and 40 GB harddrive. Mac OS X and Fedora Core 4 is installed on the machine.
Comment 1 John Eckerdal 2005-08-15 20:48:06 EDT
I forgot to mention the following:

The machine ran fine until I upgraded several libraries to the development
version (including glibc). This was the case both times this error happened.

The problem did not show directly afterwards but it took some time.

I tried to upgrade to the development version to try to fix the issue with X not
working in FC4.
Comment 2 John Eckerdal 2005-08-26 21:04:43 EDT
I have now been running this computer with my own precompiled kernel for several
days (like 10 days) without seeing the problem again. And I have been stressing
the setup quite a bit.

Besides general use I have been testing movie viewing applications with
different screen sizes and format. I have also recompiled X, GTK2 2.8.0 with
Cairo, GIMP and compiled the kernel a few times (since this is the first time I
compile a PPC kernel).

This time however I have not upgraded to the Fedora Core development libraries
for glibc (glibc 2.3.9x something I think it was). I think it should be glibc
related because the problem in both cases happened with different kernels but
same glibc installed. If I needed something from the development version I
compiled it by my self so I should not have to update glibc.

So something, probably in glibc, caused something interresting to happen. I am
still not sure exactly what. The freezing at "Freeing unused memory" is probably
not in the kernel though. I rather think it freezes when trying to start init
which causes a segmentation fault.

I think this because I have noticed that the logs on the screen is "one line
behind" the lastest kernel printout. I noticed this when I messed did not get
the initrd correctly setup so udev did not start OK. This caused the initial
console to fail. However I never got that message printed and I suspect the same
thing happens here (failed to start init or something similar should be printed
but is not).

The interresting bit is that it did not happen directly after installing. It
took sometime before it did happen. Before the second time it happened I made
sure that the coreutils, SysVinit, bash and selinux was updated to the
development versions to match the glibc version. At the moment I don't know what
could have caused the problem. 
The one think I thought about is that maybe prelink did something since to my
knowledge this runs daily as a cronjob. I did not update the prelink package.
However I don't know exactly how prelinking works and if it can cause this kind
of problem. I am just guessing a bit here.
Comment 3 David Woodhouse 2005-08-27 05:14:19 EDT
Almost certainly a duplicate of bug #154615. If you want to update from rawhide,
make sure you update prelink too -- or disable it.

X on the Mini ought to work -- I think it's just a case of getting the
configuration right. Ask on the fedora-ppc list (fedora-ppc@lists.infradead.org).

*** This bug has been marked as a duplicate of 164615 ***

Note You need to log in before you can comment on or make changes to this bug.