Bug 164627 - fence_ipmilan does not have a default operation; should be "reboot".
fence_ipmilan does not have a default operation; should be "reboot".
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 164997 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 10:24 EDT by Lon Hohberger
Modified: 2009-04-16 16:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-737
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 12:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes problem (477 bytes, patch)
2005-07-29 10:24 EDT, Lon Hohberger
no flags Details | Diff
Fixes problem in both cases (stdin + cmdline) (779 bytes, patch)
2005-07-29 10:26 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2005-07-29 10:24:04 EDT
Description of problem:

SSIA.
Comment 1 Lon Hohberger 2005-07-29 10:24:04 EDT
Created attachment 117273 [details]
Fixes problem
Comment 2 Lon Hohberger 2005-07-29 10:26:11 EDT
Created attachment 117274 [details]
Fixes problem in both cases (stdin + cmdline)
Comment 4 Adam "mantis" Manthei 2005-08-03 11:52:50 EDT
*** Bug 164997 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2005-08-04 04:41:24 EDT
Note that this bug means that the ipmilan method is unusable in production, as
fence_node doesn't work on those devices.
Comment 6 Adam "mantis" Manthei 2005-08-04 12:19:34 EDT
False.

Note that the error message indicates that you need to specify an option to the
fencing agent.  Just because there is no DEFAULT setting doesn't mean that you
can't use this as a fencing agent or that you can't use it in production.

[root@localhost ~]# cat << EOF | fence_ipmilan 
agent=fence_ipmilan
ipaddr=127.0.0.1
login=root
passwd=passwd
EOF
failed: operation must be 'on', 'off', or 'reboot'

[root@trin-02 ~]# cat << EOF | fence_ipmilan 
agent=fence_ipmilan
ipaddr=127.0.0.1
login=login
passwd=passwd
option=reboot
EOF
ipmilan: ipmitool not found!
failed: Failed to initialize

Unfortunately I don't have access to ipmi hardware at this instant to fully
demonstrate just how one would use this in production, but you should get the
idea.  

In other words, just add the option that the agent is complaining about missing.
Comment 7 Bastien Nocera 2005-08-04 12:27:24 EDT
"fence_node mymachine" will give you something like that in the syslog:
Fence of "mymachine" was unsuccessful

fence_node is what cman uses, and doesn't pass options to the underlying fence
method. Without the patch above, fence_node is useless for machines using ipmi lan.
Comment 8 Adam "mantis" Manthei 2005-08-04 13:15:33 EDT
"fence_node mymachine" queries ccs which then gets it's info from cluster.conf
and then passes the information to the agent on stdin.  The problem that I am
guessing that you are running into at the moment is that you don't have the
"option" argument specifies in /etc/cluster/cluster.conf.  Adding that option to
the cluster.conf will make the agent work for you.  

The option would look something like this:

        <fencedevices>
                <fencedevice agent="fence_ipmilan" name="ipmi" ipaddr="1.2.3.4"
                    passwd="password" login="root" action="reboot" />
        </fencedevices>

Adding "action" will make fence_ipmilan work for your setup :)

don't forget to run ccs_update after modifying it.  You can also try using
system-config-cluster, but I don't know how that will work.
Comment 9 Bastien Nocera 2005-08-05 04:32:08 EDT
Fair enough, as long as the bug is properly fixed. Thanks.
Comment 11 Red Hat Bugzilla 2005-10-07 12:56:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-737.html

Note You need to log in before you can comment on or make changes to this bug.