Bug 164997 - [PATCH] fence_node fails for IPMI LAN
[PATCH] fence_node fails for IPMI LAN
Status: CLOSED DUPLICATE of bug 164627
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam "mantis" Manthei
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 09:04 EDT by Bastien Nocera
Modified: 2009-04-16 15:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 11:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fence-set-default-action.patch (822 bytes, patch)
2005-08-03 09:04 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-08-03 09:04:36 EDT
With fence-1.32.6-0:
fence_node will not pass an action to the underlying fencing program. From the
strace:
8128  read(0,
"agent=fence_ipmilan\nipaddr=172.16.115.22\nlogin=regit\npasswd=gogo\n", 16384) = 65

Test:
# cat test
agent=fence_ipmilan
ipaddr=172.16.115.22
login=regit
passwd=gogo
# cat test | fence_ipmilan
failed: operation must be 'on', 'off', or 'reboot'

All the other fencing methods (although RPS10 is also affected) use "reboot" as
the default. Patch attached.
(Another way to do it would be for fence_node to always pass an action, but some
fencing methods don't support it either).
Comment 1 Bastien Nocera 2005-08-03 09:04:36 EDT
Created attachment 117401 [details]
fence-set-default-action.patch
Comment 2 Adam "mantis" Manthei 2005-08-03 11:50:13 EDT
Arguably, this is not a bug.  While most of the other agents do have a default
action, that doesn't mean that all agents HAVE to have a default action. 
Removing the default option forces the ccs information to be more specific,
which is a very good thing.

The reason that 'reboot' is a dangerous default action is because it does not
work for nodes that require more than one fencing device.  Take for example
nodes that have two powersupplies.  They will require two fencing devices to be
configured for that node.  If the default action of all the agents is reboot,
this can allow the user mistakenly think that they are rebooting both power
supplies at the same time, when infact, it is done serially resulting in a node
that is never actually powered off.

Moving forward, it is actually safer to have the default action be off/disable
or have no default action at all.  The down side of which is that it will
require modifications for all current users.
Comment 3 Adam "mantis" Manthei 2005-08-03 11:52:40 EDT

*** This bug has been marked as a duplicate of 164627 ***

Note You need to log in before you can comment on or make changes to this bug.