Bug 164653 - No sound input on SB Audigy (FC4)
No sound input on SB Audigy (FC4)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 164654 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 14:34 EDT by Tristan Brindle
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 04:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
very basic code to record sound using ALSA (2.17 KB, text/plain)
2005-07-30 18:51 EDT, Patrick
no flags Details
alsamixer - where's the switch for microphone?! (76.72 KB, image/jpeg)
2005-12-17 07:57 EST, Paul Osmialowski
no flags Details
No Mute/Unmute switch for the Microphone line (77.59 KB, image/jpeg)
2006-01-15 04:52 EST, Paul Osmialowski
no flags Details

  None (edit)
Description Tristan Brindle 2005-07-29 14:34:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:

I cannot use the sound inputs on my SB Audigy card under FC4. Neither the line-in nor the mic socket works.

Under both gnome-volume-control and kmix, there are no sound sources listed.

alsamixer *does* report some capture channels, but setting line-in and mic to maximum doesn't produce any results. 

ALSA is using the snd_emu10k1 module to drive the hardware. The hardware name Alsa uses is  "Audigy 1 or 2 [unknown]". I'm afraid I don't know how to get any actual hardware ID codes or anything -- if you need these please advise me!

I should mention that the hardware worked perfectly under FC3, where is was just known as an "SB Audigy". There were far more options in gnome-volume-control then though...



Version-Release number of selected component (if applicable):
alsa-lib-1.0.9rf-2.FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Witness sound recording not working on your Audigy card
3.
  

Additional info:
Comment 1 Patrick 2005-07-30 18:51:03 EDT
Created attachment 117316 [details]
very basic code to record sound using ALSA
Comment 2 Patrick 2005-07-30 19:02:19 EDT
I have a similar problem with a SoundBlaster Live! Value card and an on-board
nVidia nForce2 AC97 card under FC4.

VERSIONS
--------
Linux version 2.6.12-1.1398_FC4 (bhcompile@tweety.build.redhat.com) (gcc version
4.0.0 20050519 (Red Hat 4.0.0-8)) #1 Fri Jul 15 00:52:32 EDT 2005

Sound Blaster driver: snd_emu10k1
nVidia driver: snd_intel8x0

alsa-lib-1.0.9rf-2.FC4

AMD XP 2500+

I originally tried to record sound through sox and then audacity. Nothing worked
although both would sit there patiently until I stopped recording. On playback I
always had an entirely empty track. Later I noticed that dmesg was warning that
both programs were using the OSS emulation layer.

I compiled a simple sound recording example which uses ALSA directly (see
attachment) but that did not work for any device I passed to it either.

It returned something like this:

[patrick@localhost r]$ ./main /dev/dsp
ALSA lib pcm.c:2090:(snd_pcm_open_noupdate) Unknown PCM /dev/dsp
cannot open audio device /dev/dsp (No such file or directory)
[patrick@localhost r]$ ls -l /dev/dsp
crw-------  1 patrick root 14, 3 Jul 26 18:56 /dev/dsp

It looks to me like the file exists, I am the owner and I can read/write on the
device. I also tried turning of SELinux's enforcing mode but it made no difference.

I tried the example on:
/dev/dsp
/dev/dsp1

and these files from /dev/snd/
crw-------  1 patrick root 116, 24 Jul 26 18:56 pcmC0D0c
crw-------  1 patrick root 116, 16 Jul 26 18:56 pcmC0D0p
crw-------  1 patrick root 116, 25 Jul 26 18:56 pcmC0D1c
crw-------  1 patrick root 116, 26 Jul 26 18:56 pcmC0D2c
crw-------  1 patrick root 116, 18 Jul 26 18:56 pcmC0D2p
crw-------  1 patrick root 116, 19 Jul 26 18:56 pcmC0D3p
crw-------  1 patrick root 116, 56 Jul 26 18:56 pcmC1D0c
crw-------  1 patrick root 116, 48 Jul 26 18:56 pcmC1D0p
crw-------  1 patrick root 116, 57 Jul 26 18:56 pcmC1D1c
crw-------  1 patrick root 116, 50 Jul 26 18:56 pcmC1D2p

The microphone is plugged in. I've unmuted and turned up the volume on the mixer.
Comment 3 Patrick 2005-07-30 19:21:00 EDT
Some possibly related problems:

- Someone compared changes in emu10k1 between ALSA 1.0.9rc1 and rc2 and rc2
breaks some things.
http://sourceforge.net/mailarchive/forum.php?thread_id=6935674&forum_id=1752

Discussion on possible fixes on bottom of this Mandriva bug report:
http://qa.mandriva.com/show_bug.cgi?id=15092

The most likely fix that may explain both my SoundBlaster Live! and AC97
problems seems to be this one:
http://sourceforge.net/mailarchive/forum.php?thread_id=6944234&forum_id=1752

- A person having similar problems on SuSe 9.1 professional which may or may not
be related:
http://www.linuxquestions.org/questions/archive/47/2004/10/4/245204

- ALSA reported problem with Audigy 2:
http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg13087.html
Comment 4 Patrick 2005-07-30 19:23:05 EDT
This bug also suggests that a VIA AC97 card requires "full duplex" set be set on
the card for recording to work which may or may not be related:
http://qa.mandriva.com/show_bug.cgi?id=15642
Comment 5 Gerwin Krist 2005-07-31 09:14:45 EDT
*** Bug 164654 has been marked as a duplicate of this bug. ***
Comment 6 Vittorio Sozzi 2005-08-01 17:33:49 EDT
The same to me with SB Live! Value (emu10k1)
In the [Capture] section of alsamixer it is *impossible* to turn up the volume
of the Mic.

Seems , thoughtt, at ATRPMS solved the problem, according to this:
http://www.linuxquestions.org/questions/showthread.php?s=&threadid=339612
http://forums.fedoraforum.org/showthread.php?t=59515&page=2&pp=15

but I've not tried yet
Comment 7 Patrick 2005-08-14 18:01:55 EDT
Ok, so after some more experimentation I realized that I don't understand ALSA
(ie. trying to use /dev/dsp instead of hw:0,0 terminology) and that my sample
program I attached earlier is not necessary as I can test the ALSA stuff using
aplay and arecord. Using these ALSA programs I've determined that my on-board
nVidia nForce2 AC97 sound card DOES work for recording. The SoundBlaster Live!
Value sound card still DOES NOT work for recording as it has before in FC1-FC3.
Playback, however, is fine.

In case this is a mixer problem instead of one of the possible problems I listed
above here is a dump of my SoundBlaster mixer settings as provided by the
command 'amixer scontents':

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 30 [97%] [on]
  Front Right: Playback 29 [94%] [on]
Simple mixer control 'Headphone LFE',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Headphone',1
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Headphone Center',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Tone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'Bass',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Limits: 0 - 40
  Mono: 0 [0%]
  Front Left:
  Front Right:
Simple mixer control 'Treble',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Limits: 0 - 40
  Mono: 0 [0%]
  Front Left:
  Front Right:
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control '3D Control Sigmatel - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 3
  Mono: 0 [0%]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [on]
  Front Right: Playback 28 [90%] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'Synth',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'Wave',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 75 [75%] Capture 0 [0%] [off]
  Front Right: Playback 75 [75%] Capture 0 [0%] [off]
Simple mixer control 'Wave Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'Wave LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'Wave Surround',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Line LiveDrive',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'Line2 LiveDrive',1
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on] Capture [off]
  Front Right: Playback 23 [74%] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [on]
  Front Left: Capture [on]
  Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Mic Select',0
  Capabilities:
  Mono:
Simple mixer control 'Video',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'IEC958 Coaxial',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'IEC958 LiveDrive',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'IEC958 Optical Raw',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'IEC958 TTL',0
  Capabilities: pvolume cvolume cswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%] [off]
  Front Right: Playback 0 [0%] Capture 0 [0%] [off]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 11 [73%] [on]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 14 [93%] [on]
  Front Right: Capture 14 [93%] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'AC97',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'SB Live Analog/Digital Output Jack',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Sigmatel 4-Speaker Stereo',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Sigmatel Surround Phase Inversion Playback ',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Comment 8 Stephen Haffly 2005-08-15 02:58:39 EDT
I am having the same problem with a VIA 8237 AC'97 setup (Elitegroup KT600-A
motherboard, sound built-in).
Comment 9 Martin Stransky 2005-10-07 08:07:16 EDT
It should be fixed in 1.0.10 alsa drivers, but these drivers don't go to FC4.
You can check kernel from devel or recompile FC4 kernel with new drivers from
upstream. In this case you can use alsa-lib and alsa-utils package from devel.
Comment 10 Thomas Antony 2005-10-09 16:41:50 EDT
Why will this disturbing bug won't get fixed if there is a already existing
solution for this?!?!?
With kernel 2.6.13-1.1526 my sound is completley broken.
No sound input or even output!
Comment 11 Paul Osmialowski 2005-12-12 04:00:36 EST
I've just installed SB Audigy in my favorite desktop PC (that runs FC3) and I
have realised that no inputs are working! I've searched through groups and I've
found many traces that inputs on this card USED TO WORK with FC3. So I
downgraded the kernel to version 2.6.9 shipped primarily with FC3 and... inputs
are working properly now! WHERE'S THE PROGRESS IN THIS WORLD?

Also I must mention that I've done downgrade of xorg packages to version
6.8.1-12.FC3.21 and X runs faster now! I'm still having Radeon Value (7000),
which isn't much liked by Xorg developers. Are Windows developers better then?
Again, where the progress has gone?!
There's still lots of work to do to make Linux a good system.
Comment 12 Paul Osmialowski 2005-12-12 04:02:31 EST
Add me to CC List since I'm not happy with having old kernel.
Comment 13 Martin Stransky 2005-12-13 05:09:02 EST
New kernel update for FC4 has the 1.0.10rc drivers so it can help you.
Comment 14 Paul Osmialowski 2005-12-13 18:21:40 EST
It wasn't easy, since I had to install lots of packages from FC4 over FC3 but it
works fine now!
List of these packages is following:
alsa-lib-1.0.10-2.FC4.i386.rpm
alsa-lib-devel-1.0.10-2.FC4.i386.rpm
alsa-utils-1.0.10-1.FC4.i386.rpm
checkpolicy-1.23.1-1.i386.rpm
glib2-2.6.6-1.i386.rpm
glib2-devel-2.6.6-1.i386.rpm
hwdata-0.158.3-1.noarch.rpm
initscripts-8.11.1-1.i386.rpm
kernel-2.6.14-1.1644_FC4.i686.rpm
libselinux-1.23.10-2.i386.rpm
libselinux-devel-1.23.10-2.i386.rpm
libsepol-1.5.10-1.1.i386.rpm
libsepol-devel-1.5.10-1.1.i386.rpm
mkinitrd-4.2.15-1.i386.rpm
policycoreutils-1.27.2-1.2.i386.rpm
system-config-soundcard-1.2.12-2.noarch.rpm
SysVinit-2.85-39.i386.rpm
udev-058-1.0.FC4.1.i386.rpm

I've tried to install hal and dbus from FC4 but it needs libusb which needs
glibc from FC4, so I can't use it on FC3.
Also I must mention, that I had to configure arts and xmms to use OSS instead of
ALSA. Fortunately, alsamixer works properly.
Comment 15 Paul Osmialowski 2005-12-17 07:57:38 EST
Created attachment 122366 [details]
alsamixer - where's the switch for microphone?!

Afrer some time (as I have installed Skype), I realised that there's still a
problem with inputs. There's no microphone ON/OFF switch in alsamixer (nor in
any other mixers). Strangely, there's ON/OFF switch for Mic Boost (see attached
snapshot). What should be changed this time to make my Mike working?
Comment 16 Martin Stransky 2005-12-30 09:54:59 EST
You have to use "alsamixer -V capture" for access to the capture settings. It
was splited into playback and capture interface....
Comment 17 Martin Stransky 2006-01-03 10:28:48 EST
Some how-to for the latest alsa-driver and FC4 is here:
http://people.redhat.com/stransky/alsa/

Comment 18 Paul Osmialowski 2006-01-05 12:09:59 EST
Thanks for your advices Martin, -V capture option works fine, however there's no
unmute switch for Mic there. Anyway, I was able to use Mic after I've set the
volume to the max for it on the Capture.
Comment 19 Martin Stransky 2006-01-12 05:32:06 EST
If you use "alsamixer -V All" you should see all controls...
Comment 20 Paul Osmialowski 2006-01-15 04:52:26 EST
Created attachment 123213 [details]
No Mute/Unmute switch for the Microphone line

As you can see on the attached image, while using -V All there's no Mute/Unmute
switch for Microphone line. However, for other input lines (Line1, CD, Aux)
such a switch is available. Fortunately, changing volume for <Mic Capt> was
enough to make my mike working on Skype.
Comment 21 Martin Stransky 2006-01-16 04:24:31 EST
Recording should be fixed in the latest drivers. Please reopen this bug if
anyone here still has a problem with recording.

Note You need to log in before you can comment on or make changes to this bug.