Bug 1646741 - While upgrading satellite from 6.3->6.4, satellite-installer does not perform remove_legacy_mongo step in some situations which results in error
Summary: While upgrading satellite from 6.3->6.4, satellite-installer does not perform...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.4
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: 6.4.1
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL: https://projects.theforeman.org/issue...
Whiteboard:
Depends On:
Blocks: 1647339
TreeView+ depends on / blocked
 
Reported: 2018-11-05 22:50 UTC by Mike McCune
Modified: 2019-10-30 19:38 UTC (History)
16 users (show)

Fixed In Version: katello-installer-base-3.7.0.11-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1640686
Environment:
Last Closed: 2018-12-06 22:32:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 25336 'High' 'Closed' 'While upgrading satellite from 6.3->6.4, satellite-installer does not perform remove_legacy_mongo step in some situatio... 2019-12-06 09:50:12 UTC
Github Katello katello-installer pull 707 'None' 'closed' 'Fixes #25336 - Move remove MongoDB from post to pre hook.' 2019-12-06 09:50:12 UTC
Red Hat Bugzilla 1651960 'unspecified' 'CLOSED' 'Upgrade from 6.4.0 to 6.4.1 failed at Upgrade Step: remove_legacy_mongo' 2019-12-06 09:50:10 UTC
Red Hat Knowledge Base (Solution) 3658241 None None None 2018-11-05 22:50:20 UTC
Red Hat Product Errata RHBA-2018:3799 None None None 2018-12-06 22:33:26 UTC

Internal Links: 1651960

Comment 2 Jitendra Yejare 2018-11-16 06:02:14 UTC
Verified!

@ Satellite 6.4 snap 1


Steps:

1. Satellite 6.3 CDN installed
2. Upgrade to 6.4.1 snap 1


Observation:

1. The issue is not reproducible on the machine where it was reproducible:
yum remove -y mongodb-2* mongodb-server-2* > /dev/null 2>&1 finished successfully!
rm -rf /etc/mongod.conf /var/log/mongodb finished successfully!

2. Also, the issue with 'yum install -y -q rh-mongodb34-syspaths failed! C' is now solved.
# rpm -qa | grep syspath
rh-mongodb34-mongo-tools-syspaths-3.4.7-1.el7.x86_64
rh-mongodb34-mongodb-server-syspaths-3.4.9-1.el7.x86_64
rh-mongodb34-syspaths-3.0-14.el7.x86_64
rh-mongodb34-mongodb-syspaths-3.4.9-1.el7.x86_64

Comment 4 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799


Note You need to log in before you can comment on or make changes to this bug.