Bug 1651960 - Upgrade from 6.4.0 to 6.4.1 failed at Upgrade Step: remove_legacy_mongo
Summary: Upgrade from 6.4.0 to 6.4.1 failed at Upgrade Step: remove_legacy_mongo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.4.1
Assignee: Chris Roberts
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 10:04 UTC by Nikhil Kathole
Modified: 2019-10-30 19:38 UTC (History)
6 users (show)

Fixed In Version: katello-installer-base-3.7.0.12-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-06 22:32:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1646741 None CLOSED While upgrading satellite from 6.3->6.4, satellite-installer does not perform remove_legacy_mongo step in some situation... 2019-07-23 08:45:28 UTC
Red Hat Product Errata RHBA-2018:3799 None None None 2018-12-06 22:33:02 UTC

Internal Links: 1646741

Description Nikhil Kathole 2018-11-21 10:04:11 UTC
Description of problem:

z-stream upgrade i.e. 6.4.0 to 6.4.1 upgrade failed at 

<trimmed>
Upgrade Step: migrate_foreman...
/usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
/usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
/usr/share/foreman/lib/core_extensions.rb:182: warning: already initialized constant ActiveSupport::MessageEncryptor::DEFAULT_CIPHER
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/message_encryptor.rb:22: warning: previous definition of DEFAULT_CIPHER was here
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::ERRATA_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:7: warning: previous definition of ERRATA_STATUS_MAP was here
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: already initialized constant Katello::Concerns::ContentFacetHostExtensions::TRACE_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/content_facet_host_extensions.rb:14: warning: previous definition of TRACE_STATUS_MAP was here
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: already initialized constant Katello::Concerns::SubscriptionFacetHostExtensions::SUBSCRIPTION_STATUS_MAP
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.7.0.42/app/models/katello/concerns/subscription_facet_host_extensions.rb:13: warning: previous definition of SUBSCRIPTION_STATUS_MAP was here
foreman-rake db:migrate finished successfully!
Upgrade Step: remove_legacy_mongo...
Upgrade step remove_legacy_mongo failed. Check logs for more information.
 


Version-Release number of selected component (if applicable):

Upgrade from 6.4.0 to 6.4.1


How reproducible: always


Steps to Reproduce:
1. foreman-maintain upgrade run --target-version 6.4.z -y

Actual results:
Upgrade failed at Upgrade Step: remove_legacy_mongo


Expected results: Successful upgrade.


Additional info:

Comment 2 Nikhil Kathole 2018-11-21 10:12:28 UTC
Regression from https://bugzilla.redhat.com/show_bug.cgi?id=1646741

Comment 4 Patrick Creech 2018-11-21 13:01:03 UTC
Nikhil,

The bug you attached that you stated this is a regression from is also on 6.4.1 snap 1, shouldn't that bug be FailedQA instead of creating a new regression?

Comment 5 Nikhil Kathole 2018-11-21 13:07:33 UTC
Hi Patrick,

I raised this to track issue separately as both the scenarios need to validate while testing/verifying.

If you want, feel free to close this duplicate and failedQA another bug with comment to verify z-stream upgrade as well.

I am ok with that.

Comment 6 Patrick Creech 2018-11-21 13:09:55 UTC
Ah, ok.  I didn't pick up on that z-stream nuance.   Sounds good to me, apologies for the nosie

Comment 15 Nikhil Kathole 2018-12-03 13:35:26 UTC
VERIFIED

Version tested:

Satellite 6.4.1 snap 2

Upgrade from 6.4.0 to 6.4.1 is successful.

foreman-rake db:migrate finished successfully!
 Upgrade Step: remove_legacy_mongo...
 Upgrade Step: Running installer...
 Preparing installation Debug: Loading facts from /usr/share/foreman-insta[[KPreparing installation Info: Facter: loading custom facts from /usr/share[[KPreparing installation Debug: Facter: searching for

Comment 17 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799


Note You need to log in before you can comment on or make changes to this bug.