Bug 164688 - usbdisk gets mounted twice
usbdisk gets mounted twice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-30 06:51 EDT by Christophe Lambin
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 13:42:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant part of /var/log/messages (2.55 KB, text/plain)
2005-07-30 06:51 EDT, Christophe Lambin
no flags Details
Content of /proc/bus/usb/devices (4.32 KB, text/plain)
2005-07-30 06:53 EDT, Christophe Lambin
no flags Details
usbmon trace (65.79 KB, text/plain)
2005-07-31 03:33 EDT, Christophe Lambin
no flags Details
Candidate #1 - add US_FL_SINGLE_LUN (660 bytes, patch)
2005-08-23 17:01 EDT, Pete Zaitcev
no flags Details | Diff
/var/log/messages of two USB Memory Sticks (4.22 KB, text/plain)
2005-12-01 15:32 EST, Robert Locke
no flags Details
Content of /proc/bus/usb/devices (2.26 KB, text/plain)
2006-09-12 11:10 EDT, Robert Locke
no flags Details

  None (edit)
Description Christophe Lambin 2005-07-30 06:51:47 EDT
Description of problem:
Whenever I plug in my usbdisk, FC4 will mount it twice: once on /media/usbdisk
and once on /media/usbdisk1.  Looking at /var/log/messages (attached), it seems
it's the kernel who incorrectly sees it as two devices.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1398_FC4

How reproducible:
Always
Comment 1 Christophe Lambin 2005-07-30 06:51:48 EDT
Created attachment 117306 [details]
relevant part of /var/log/messages
Comment 2 Christophe Lambin 2005-07-30 06:53:34 EDT
Created attachment 117307 [details]
Content of /proc/bus/usb/devices
Comment 3 Pete Zaitcev 2005-07-31 01:01:44 EDT
What is the claimed capacity of the disk? 128MB or 256MB?

Also, please get me a usbmon trace (not sure if it captures the data
with the number of LUNs, but it's worth trying). Here's how:
 mount -t debugfs none /sys/kernel/debug
 modprobe usbmon    # Not really needed, but in case config is changed
 cat /sys/kernel/debug/usbmon/5t > /tmp/run.mon
 # insert here
 ^C
Attach run.mon.
Comment 4 Christophe Lambin 2005-07-31 03:33:37 EDT
Created attachment 117320 [details]
usbmon trace

Here's the requested usbmon trace. The claimed capacity if the usbdisk is 128
MB.
Comment 5 Pete Zaitcev 2005-07-31 21:59:32 EDT
Unfortunately, usbmon cannot get the needed information at present.
This is the GetMaxLUN:

f0cb8e00 2165649817 S Ci:002:00 -115 1 D
f0cb8e00 2165651373 C Ci:002:00 0 1 D

For the time being I suggest running with automatic mounting disabled
(it's done in Removable Media properties panel)
Comment 6 Dave Jones 2005-08-04 02:21:03 EDT
What type of device is this btw ?
Comment 7 Christophe Lambin 2005-08-04 13:26:10 EDT
You mean the usbdrive? I don't really know: I got it from my company and it's
got my company's logo on it, so not clear who the original vendor is.
Comment 8 Pete Zaitcev 2005-08-23 17:01:24 EDT
Created attachment 118024 [details]
Candidate #1 - add US_FL_SINGLE_LUN
Comment 9 Pete Zaitcev 2005-08-23 17:03:11 EDT
We have a candidate patch, but I think for Fedora it's better to
move it through upstream. I'm going to take care of it.
Comment 10 Dave Jones 2005-09-30 03:20:32 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 11 Robert Locke 2005-10-04 08:49:21 EDT
As another data point, the new kernel does NOT resolve this issue.  I still get
two devices sda and sdb created when I insert the USB Memory Stick.  The stick I
am testing with is only 32MB in capacity (the one Red Hat gives away in it's
classes).  My other difference is that I am NOT running the smp kernel, just the
up one.
Comment 12 Dave Jones 2005-11-10 15:29:29 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 13 Robert Locke 2005-11-11 12:17:07 EST
Just upgraded last night to 2.6.14-1.1637_FC4 (not the smp one) on my laptop and
still no joy.   Kernel recognizes the USB memstick as sda1 and sdb1 which are
then automounted by gnome.....  Anything else I can provide to test?
Comment 14 Robert Locke 2005-12-01 15:32:14 EST
Created attachment 121704 [details]
/var/log/messages of two USB Memory Sticks

Borrowed someone's 1GB USB Mem Stick and it only got automounted once (on
2.6.14-1.1644_FC4 kernel).  Grabbed the one I have had the "problem" with and
it still mounts twice.	Attached the relevant /var/log/messages entries to see
if it can help glean the difference and hence problem....
Comment 15 Dave Jones 2006-02-03 02:27:57 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 16 Robert Locke 2006-02-03 10:59:54 EST
Still no joy.  The stick that I have consistently tested with is still getting
mounted twice.  Let me know if there are any other specifics or information that
I can do to help.
Comment 17 Pete Zaitcev 2006-09-11 19:42:31 EDT
Robert, you need to attach some information with PID/VID so that I can
blacklist the device. The /var/log/messages does not work for this purpose
anymore. So, either /proc/bus/usb/devices, or a usbmon trace would do.
Usbmon is better, it lets me see what actually happens.

Chris's device is upstream since... 2.6.17 or so. It should be working
fine by now.
Comment 18 Robert Locke 2006-09-12 11:10:18 EDT
Created attachment 136081 [details]
Content of /proc/bus/usb/devices
Comment 19 Robert Locke 2006-09-12 11:12:01 EDT
I just tested and the stick is happy now (frankly hadn't used that stick in a
while since it was so small)....  I am now running 2.6.17-1.2174_FC5....
Comment 20 Pete Zaitcev 2006-09-12 13:42:31 EDT
Ahh, so it was the same device as Christophe's after all. OK, closing the bug.
Thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.