Bug 1647181 - Cinnamon missing deps in 7.6
Summary: Cinnamon missing deps in 7.6
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: cinnamon
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1647392 (view as bug list)
Depends On:
Blocks: EPEL7-Deps
TreeView+ depends on / blocked
 
Reported: 2018-11-06 19:54 UTC by Pat Riehecky
Modified: 2019-04-04 21:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-08 19:00:28 UTC


Attachments (Terms of Use)

Description Pat Riehecky 2018-11-06 19:54:47 UTC
Description of problem:
Cinnamon 3.6.7 depends on caribou, however, that is RPM obsolete in gnome-shell-3.28.3-6.el7

Version-Release number of selected component (if applicable):
cinnamon-3.6.7-3.el7

How reproducible:
100%

Steps to Reproduce:
1.Update to RHEL 7.6 and install cinnamon
2.
3.

Actual results:
Error: Package: cinnamon-3.6.7-3.el7.x86_64 (@epel)
           Requires: caribou(x86-64)
           Removing: caribou-0.4.21-1.el7.x86_64 (@anaconda/7.5)
               caribou(x86-64) = 0.4.21-1.el7
           Obsoleted By: gnome-shell-3.28.3-6.el7.x86_64 (localmirror)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Can install

Additional info:
This is a change in RHEL7.6 from RHEL 7.5

Comment 1 leigh scott 2018-11-06 19:57:06 UTC
I no longer support RHEL.

Comment 2 Stephen John Smoogen 2018-11-06 21:17:08 UTC
Leigh, if you no longer wish to support this package in RHEL or CentOS, please retire the package from EPEL so it can be removed from the repository

Comment 3 leigh scott 2018-11-06 23:05:26 UTC
(In reply to Stephen John Smoogen from comment #2)
> Leigh, if you no longer wish to support this package in RHEL or CentOS,
> please retire the package from EPEL so it can be removed from the repository

I've run this for the following epel7 packages (fedpkg retire 'Not enough time to maintain').

cinnamon
cinnamon-control-center
cinnamon-desktop
cinnamon-menus
cinnamon-screensaver
cinnamon-session
cinnamon-settings-daemon
cinnamon-translations
cjs
mintlocale
mint-themes
mint-x-icons
mint-y-icons
muffin
nemo
nemo-extensions
python-xapp
tint2
xapps
xed
xreader


Is that all that is required as I'm clueless to the process since pkgdb was retired.
The notes for the new infra are totally lacking IMO.

Comment 4 leigh scott 2018-11-07 12:10:56 UTC
*** Bug 1647392 has been marked as a duplicate of this bug. ***

Comment 5 Pat Riehecky 2018-11-08 17:12:56 UTC
This was reassigned to Alternative GTK desktop environments.  I'll reopen for now to see if someone there is interested in maintaining for RHEL.

Comment 6 leigh scott 2018-11-08 19:00:28 UTC
(In reply to Pat Riehecky from comment #5)
> This was reassigned to Alternative GTK desktop environments.  I'll reopen
> for now to see if someone there is interested in maintaining for RHEL.

Alternative GTK desktop environments = 3 people including me.

me = not interested
raveit65 = busy with mate or not interested
besser82 = MIA or not interested

Comment 7 Pat Riehecky 2018-11-28 18:47:43 UTC
I'd be willing to maintain these and an EPEL7 branch of caribou.

FAS account name: jcpunk

Can I be granted the relevant rights?

Comment 8 Steve Cleveland 2019-04-04 20:55:47 UTC
Any updates on this?  I would love to see Cinnamon continue to be supported in EPEL.  I have a ton of users using it. jcpunk appears to have volunteered to maintain it.

Comment 9 Stephen John Smoogen 2019-04-04 21:04:18 UTC
The packages have been in epel-testing but no one seems to be actually testing them and giving jcpunk the karma so they can be pushed.


Note You need to log in before you can comment on or make changes to this bug.