Bug 164790 - Current gnomemeeting doesn't rebuild on rawhide systems
Summary: Current gnomemeeting doesn't rebuild on rawhide systems
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pwlib   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
: 164996 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-01 14:21 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: pwlib-1.8.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 22:15:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2005-08-01 14:21:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050723 Fedora/1.1-0.2.4.deerpark.alpha2 Firefox/1.0+

Description of problem:
Current gnomemeeting doesn't rebuild on rawhide systems.
This should be fixed before the next massrebuild:

g++ -DHAVE_CONFIG_H -I. -I. -I../.. -DGNOMELOCALEDIR=\"/usr/share/locale/\" -DG_LOG_DOMAIN=\"GnomeMeeting\" -DSHARE_DIR=\"/usr/share/gnomemeeting\" -I../.. -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -DORBIT2=1 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/libxml2 -I/usr/include/libgnome-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/libbonoboui-2.0 -DORBIT2=1 -pthread -I/usr/include/evolution-data-server-1.4 -I/usr/include/libbonobo-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/libxml2 -I/usr/include/howl-0.9.8 -DHAS_HOWL -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -DORBIT2=1 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/libxml2 -I/usr/include/libgnome-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/libbonoboui-2.0 -DORBIT2=1 -pthread -I/usr/include/evolution-data-server-1.4 -I/usr/include/libbonobo-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/libxml2 -I/usr/include/howl-0.9.8 -DHAS_HOWL -I/usr/include/ptlib -I/usr/include/ptclib -I/usr/include/openh323 -I/usr/include/SDL -D_REENTRANT -DHAS_SDL -I/usr/include -DPTRACING -DNDEBUG -Wall -Os -g -D_REENTRANT -fno-exceptions -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -MT gm_contacts-remote.lo -MD -MP -MF .deps/gm_contacts-remote.Tpo -c gm_contacts-remote.cpp  -fPIC -DPIC -o .libs/gm_contacts-remote.o
/usr/include/ptlib/timer.h:363: error: expected ';' before '*' token
/usr/include/ptlib/unix/ptlib/pprocess.h:175: error: expected ';' before '*' token
make[3]: *** [gm_contacts-remote.lo] Error 1
make[3]: Leaving directory `/home/build/rebuild/build/gnomemeeting-1.2.1-1.src.rpm/gnomemeeting-1.2.1/lib/contacts'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/build/rebuild/build/gnomemeeting-1.2.1-1.src.rpm/gnomemeeting-1.2.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/build/rebuild/build/gnomemeeting-1.2.1-1.src.rpm/gnomemeeting-1.2.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/gnomemeeting-1.2.1-1.src.rpm/rpm-tmp.97189 (%build)


Version-Release number of selected component (if applicable):
gnomemeeting-1.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. try to rebuild gnomemeeting on a rawhide system
2.
3.
  

Additional info:

Comment 1 Daniel Veillard 2005-08-01 14:55:19 UTC
One more reason to look at packaging the update then, 

I'm gonna look at it this week,

  thanks,

Daniel

Comment 2 Daniel Veillard 2005-08-03 13:11:58 UTC
*** Bug 164996 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Veillard 2005-08-03 13:44:01 UTC
There is no pwlib update upstream, this is a header defined within pwlib-devel
package.

/usr/include/ptlib/timer.h:362 does:

  friend class PTimerList;
    PTimerList * timerList;

whithin class PTimer : public PTimeInterval { } definition

http://gnu.miscellaneousmirror.org/software/gcc/gcc-4.0/changes.html
indicates changes w.r.t. friend class support but nothing about 
a construct which would not be supported anymore, and I don't understand
this specific construct so I can't tell if this is a gcc problem or a 
problem upstream, but I didn't see any report of pwlib compilation
problems on the gnomemeeting mailing-list.

Daniel

Comment 4 Daniel Veillard 2005-08-03 14:31:08 UTC
I found this patch on-line in pwlib CVS:

http://cvs.sourceforge.net/viewcvs.py/openh323/pwlib/include/ptlib/timer.h?r1=1.27&r2=1.27.10.1

I still have no idea if pwlib is guilty or gcc but I will try to get this patch in

Daniel

Comment 5 Daniel Veillard 2005-08-04 09:27:57 UTC
that and another patch adding a class identifier allowed to rebuild pwlib-1.8.4
on rawhide: pwlib-1.8.4-2 is in Rawhide fixing the problem. Not sure it's
actually a gcc bug, I asked for clarification upstream,

Daniel

Comment 6 Jakub Jelinek 2005-08-05 21:56:28 UTC
It is a pwlib bug.
Without the
http://cvs.sourceforge.net/viewcvs.py/openh323/pwlib/include/ptlib/timer.h?r1=1.27&r2=1.27.10.1
patch the source is not valid ISO C++.
See http://gcc.gnu.org/PR1016 for details.

Comment 7 Daniel Veillard 2005-08-05 22:15:54 UTC
Okidoc, thanks !
Bug fixed by the build pwlib-1.8.4-2
I checked with upstream the next release will have the fix

Daniel


Note You need to log in before you can comment on or make changes to this bug.