Bug 164996 - openh323 won't rebuild on a rawhide system
openh323 won't rebuild on a rawhide system
Status: CLOSED DUPLICATE of bug 164790
Product: Fedora
Classification: Fedora
Component: openh323 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 08:58 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 09:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-08-03 08:58:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
openh323-1.15.3-1 won't rebuild on a current rawhide system. It fails with this
error:

make[2]: Entering directory `/home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3/src'
g++  -D_REENTRANT -fno-exceptions -Wall  -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -fPIC -DPTRACING -I/home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3/include -DHAS_OSS -I/usr/share/pwlib//include -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -felide-constructors -x c++ -c h225_1.cxx -o /home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3/lib/obj_linux_x86_r/h225_1.o
/usr/include/ptlib/timer.h:363: error: expected ';' before '*' token
/usr/include/ptlib/unix/ptlib/pprocess.h:175: error: expected ';' before '*' token
make[2]: *** [/home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3/lib/obj_linux_x86_r/h225_1.o] Error 1
make[2]: Leaving directory `/home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3/src'
make[1]: *** [opt] Error 2
make[1]: Leaving directory `/home/build/rebuild/build/openh323-1.15.3-1.src.rpm/openh323-1.15.3'
make: *** [optshared] Error 2
error: Bad exit status from /var/tmp/openh323-1.15.3-1.src.rpm/rpm-tmp.23556 (%build)


Version-Release number of selected component (if applicable):
openh323-1.15.3-1

How reproducible:
Always

Steps to Reproduce:
1.try to rebuild on a rawhide system
2.
3.
  

Additional info:

This should be fixed before the next mass rebuild
Comment 1 Daniel Veillard 2005-08-03 09:11:50 EDT
Same problem as 164790 for some reason a C++ construct in pwlib header
doesn't pass any more though g++

Daniel

*** This bug has been marked as a duplicate of 164790 ***

Note You need to log in before you can comment on or make changes to this bug.