Bug 164816 - kernel-2.6.12-1.1372_FC3 will not boot if cdrw is connected
kernel-2.6.12-1.1372_FC3 will not boot if cdrw is connected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 12:16 EDT by Anthony Messina
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 01:33:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Messina 2005-08-01 12:16:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
i upgraded my ibm thinkpad r30 which has a sony crx700e removable cdrw drive from kernel-2.6.11-1.35_FC3 to kernel-2.6.11-1.1372_FC3 and the computer will not finish booting if the cdrw drive is in the bay.  it is an ide cdrw.  i get the error:

Disabling IRQ #15
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 24X CDROM CD-R/RW...
hdc: lost interrupt

and the computer hangs there.  there were no issues with the previous install.  i have searched the web extensively and tried boot options like noacpi, acpi=off, acpi_irq_balance, and hdc=ide-scsi.

the only boot parameter that allows the computer to continue booting is hdc=ide-scsi, but once i am logged in after using that command, my cdrw is completely inaccessible and does not show up anywhere in the /dev folder.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. install kernel-2.6.12-1.1372_FC3
2. boot using that kernel
3. wait for the computer to give the errors
  

Actual Results:  see description

Expected Results:  computer will boot as normal and cdrw drive will be accessable after booting

Additional info:

no workaround is present, that's why i've classified the severity as high.
Comment 1 Anthony Messina 2005-08-01 13:27:56 EDT
i made a mistake in my previous submission...  (i am new at this).  if i use
acpi=off as a boot option, the system loads just like it used to and i can use
the cdrw drive.  changing severity to low because this is something that should
be detected on kernel upgrade.
Comment 2 Dan Carpenter 2005-08-01 13:46:00 EDT
This sounds the same as bug 162347 

Comment 3 Dave Jones 2005-08-01 19:42:16 EDT
no, this is something else, note the problem here is seen on the latest errata
kernel.
Comment 4 Alan Cox 2005-08-08 08:43:58 EDT
IRQ routing not IDE
Comment 5 Dave Jones 2005-08-26 20:33:24 EDT
Can you try the kernel from updates-testing please ?

Note You need to log in before you can comment on or make changes to this bug.