Bug 1648289 - Grafana iframes for various roles
Summary: Grafana iframes for various roles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: 4.0
Assignee: Kanika Murarka
QA Contact: Sunil Angadi
URL:
Whiteboard:
: 1652987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-09 10:32 UTC by Kanika Murarka
Modified: 2020-02-07 22:39 UTC (History)
5 users (show)

Fixed In Version: 3.2-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 24851 0 None None None 2018-11-15 11:28:41 UTC
Github ceph ceph pull 24851 0 'None' closed mgr/dashboard: Show/Hide Grafana tabs according to user role 2020-07-10 08:23:28 UTC
Github rhcs-dashboard/ceph/commit/1f4deb56aa 0 None None None 2020-07-10 08:23:27 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:06 UTC

Description Kanika Murarka 2018-11-09 10:32:56 UTC
Description of problem:
Grafana tabs shows errors 403 for roles others than admin, read-only and cluster-manager.

How reproducible:
100%

Steps to Reproduce:
1. Login with a Rgw manager rights user
2. Click Objects -> Daemons
3. A 403 error page shows up

Actual results:
403 error

Expected results:
Tabs for grafana should only be viewed for roles having Grafana Scope rights.

Comment 3 Kanika Murarka 2018-11-15 08:58:05 UTC
Upstream tracker: http://tracker.ceph.com/issues/36655
Upstream PR: https://github.com/ceph/ceph/pull/24851

Comment 4 Ernesto Puerta 2018-11-23 20:50:46 UTC
*** Bug 1652987 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2020-01-31 12:44:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.