Bug 1648298 - dht_revalidate may not heal attrs on the brick root
Summary: dht_revalidate may not heal attrs on the brick root
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1648296 1660736 1693057
TreeView+ depends on / blocked
 
Reported: 2018-11-09 10:59 UTC by Nithya Balachandran
Modified: 2019-03-27 04:01 UTC (History)
5 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1648296
: 1660736 1693057 (view as bug list)
Environment:
Last Closed: 2019-03-25 16:31:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21611 0 None Merged cluster/dht: sync brick root perms on add brick 2018-11-19 05:45:15 UTC

Description Nithya Balachandran 2018-11-09 10:59:25 UTC
+++ This bug was initially created as a clone of Bug #1648296 +++

Description of problem:


In dht_revalidate_cbk, the stbuf returned by the brick is merged into local->stbuf only if the dir contains a layout. local->stbuf is also used to compare the stbuf returned in responses to check if an attr heal is needed.

If the newly added brick (which does not contain a layout) is the first one to respond, its stbuf is not merged into local->stbuf. Subsequent responses from existing bricks never see a mismatch in the stbuf and self heal is not triggered.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-11-09 05:58:05 EST ---

This bug is automatically being proposed for a Z-stream release of Red Hat Gluster Storage 3 under active development and open for bug fixes, by setting the release flag 'rhgs‑3.4.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

Comment 1 Worker Ant 2018-11-09 11:59:55 UTC
REVIEW: https://review.gluster.org/21611 (cluster/dht: sync brick root perms on add brick) posted (#1) for review on master by N Balachandran

Comment 2 Worker Ant 2018-11-19 05:45:13 UTC
REVIEW: https://review.gluster.org/21611 (cluster/dht: sync brick root perms on add brick) posted (#5) for review on master by N Balachandran

Comment 3 Shyamsundar 2019-03-25 16:31:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.