Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1660736 - dht_revalidate may not heal attrs on the brick root
Summary: dht_revalidate may not heal attrs on the brick root
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1648298 1693057
Blocks: 1648296
TreeView+ depends on / blocked
 
Reported: 2018-12-19 06:12 UTC by Nithya Balachandran
Modified: 2019-03-27 04:01 UTC (History)
5 users (show)

Fixed In Version: glusterfs-5.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1648298
Environment:
Last Closed: 2019-01-22 14:08:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21886 0 None Merged cluster/dht: sync brick root perms on add brick 2018-12-26 16:41:05 UTC

Description Nithya Balachandran 2018-12-19 06:12:06 UTC
+++ This bug was initially created as a clone of Bug #1648298 +++

+++ This bug was initially created as a clone of Bug #1648296 +++

Description of problem:


In dht_revalidate_cbk, the stbuf returned by the brick is merged into local->stbuf only if the dir contains a layout. local->stbuf is also used to compare the stbuf returned in responses to check if an attr heal is needed.

If the newly added brick (which does not contain a layout) is the first one to respond, its stbuf is not merged into local->stbuf. Subsequent responses from existing bricks never see a mismatch in the stbuf and self heal is not triggered.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-11-09 05:58:05 EST ---

This bug is automatically being proposed for a Z-stream release of Red Hat Gluster Storage 3 under active development and open for bug fixes, by setting the release flag 'rhgs‑3.4.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Worker Ant on 2018-11-09 11:59:55 UTC ---

REVIEW: https://review.gluster.org/21611 (cluster/dht: sync brick root perms on add brick) posted (#1) for review on master by N Balachandran

--- Additional comment from Worker Ant on 2018-11-19 05:45:13 UTC ---

REVIEW: https://review.gluster.org/21611 (cluster/dht: sync brick root perms on add brick) posted (#5) for review on master by N Balachandran

Comment 1 Worker Ant 2018-12-19 06:24:57 UTC
REVIEW: https://review.gluster.org/21886 (cluster/dht: sync brick root perms on add brick) posted (#1) for review on release-5 by N Balachandran

Comment 2 Worker Ant 2018-12-26 16:41:05 UTC
REVIEW: https://review.gluster.org/21886 (cluster/dht: sync brick root perms on add brick) posted (#3) for review on release-5 by Shyamsundar Ranganathan

Comment 3 Shyamsundar 2019-01-22 14:08:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.3, please open a new bug report.

glusterfs-5.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-January/000118.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.