Bug 1649711 - CephFS-manager role is not working
Summary: CephFS-manager role is not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 3.*
Assignee: Ernesto Puerta
QA Contact: Ernesto Puerta
URL:
Whiteboard:
: 1651105 1651125 1651126 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 10:38 UTC by Uday kurundwade
Modified: 2019-08-26 06:50 UTC (History)
2 users (show)

Fixed In Version: 3.2-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-26 06:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of forbidden page (63.60 KB, image/png)
2018-11-14 10:38 UTC, Uday kurundwade
no flags Details


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 37293 None None None 2018-11-16 18:16:59 UTC
Github ceph ceph pull 25141 None None None 2018-11-16 18:17:41 UTC
Github rhcs-dashboard/ceph/commit/6f26cabafb None None None 2018-11-20 15:57:21 UTC

Description Uday kurundwade 2018-11-14 10:38:34 UTC
Created attachment 1505603 [details]
Screenshot of forbidden page

Description of problem:
CephFS-manager is roles not working in dashboard

Version-Release number of selected component (if applicable):
ceph-common-12.2.8-23.el7cp.x86_64
ceph-ansible-3.2.0-0.1.beta9.el7cp.noarch
ceph-mgr-12.2.8-23.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install ceph storage with CephFS
2.Install "dashboard v2" by running ansible playbook
3.Login to dashboard after installation of dashboard v2
4.Create new user and assign "CephFS manager" role to that user. 
5.Log in with newly created CephFS manager user.
6.Navigate to File system tab, Click on configured cephFS.

Actual results:
Throwing 403 Forbidden error (Sorry, you are not allowed to see what you were looking for)

Expected results:
It should be accessible

Additional info:
It is accessible through Administrator role

Comment 3 Ernesto Puerta 2018-11-16 17:36:36 UTC
The cause for this error is that the CephFS page requests the Grafana URL from  /api/settings/GRAFANA_API_URL endpoint, which requires ConfigOpts read permission.

While this should be fixed upstream, I'll provide a tested workaround to allow going on testing CephFS:

1. As admin user go to "User Management" (top-right cog icon).
2. Roles-> +Add new role
3. Name: cephfs-manager-fixed
4. Permissions: cephfs: ALL + config-opt: Read
5. Create Role.

Comment 4 Ernesto Puerta 2018-11-19 11:23:44 UTC
*** Bug 1651105 has been marked as a duplicate of this bug. ***

Comment 5 Ernesto Puerta 2018-11-19 11:24:05 UTC
*** Bug 1651125 has been marked as a duplicate of this bug. ***

Comment 6 Ernesto Puerta 2018-11-19 11:24:29 UTC
*** Bug 1651126 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.