Bug 1651126 - pool-manager is roles not working in dashboard
Summary: pool-manager is roles not working in dashboard
Keywords:
Status: CLOSED DUPLICATE of bug 1649711
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 3.*
Assignee: Ernesto Puerta
QA Contact: Ernesto Puerta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 09:14 UTC by Uday kurundwade
Modified: 2018-11-19 11:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 11:24:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of forbidden page (45.82 KB, image/png)
2018-11-19 09:14 UTC, Uday kurundwade
no flags Details

Description Uday kurundwade 2018-11-19 09:14:49 UTC
Created attachment 1507147 [details]
Screenshot of forbidden page

Description of problem:
pool-manager is roles not working in dashboard

Version-Release number of selected component (if applicable):
ceph-mgr-12.2.8-32.el7cp.x86_64
ceph-ansible-3.2.0-0.1.beta9.el7cp.noarch
ceph-common-12.2.8-32.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install ceph storage
2.Install "dashboard v2" by running ansible playbook
3.Login to dashboard after installation of dashboard v2
4.Create new user and assign "pool-manager" role to that user. 
5.Log in with newly created pool-manager user.
6.Navigate to Pool page

Actual results:
Throwing 403 Forbidden error (Sorry, you are not allowed to see what you were looking for)

Expected results:
It should be accessible

Additional info:
It is accessible through Administrator role

Comment 3 Ernesto Puerta 2018-11-19 11:24:29 UTC

*** This bug has been marked as a duplicate of bug 1649711 ***


Note You need to log in before you can comment on or make changes to this bug.