Bug 164994 - Anaconda crashed with core when the system should format the hard drive
Anaconda crashed with core when the system should format the hard drive
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 08:30 EDT by Kenneth Heal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 15:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dump (848.07 KB, text/plain)
2005-08-03 08:32 EDT, Kenneth Heal
no flags Details

  None (edit)
Description Kenneth Heal 2005-08-03 08:30:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
During a graphic installation Anaconda reported the following error:

Error: Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you shouldn't mount it or use it in any way before rebooting.

After selecting Ignore and attempting to move on with the install it crashed.

The onboard ATA Western Digital Hard-disk had an NTFS partition with Windows XP on it, which was due to be completely erased for FC4.

Version-Release number of selected component (if applicable):
fc4

How reproducible:
Didn't try

Steps to Reproduce:
1. Boot using Anaconda, select workstation install.
2. Added extra packages.
3. Select erase whole hard disk for FC4.
4. Attempt to proceed with install.
  

Actual Results:  The system crashed, after this the XP boot process starts but appears to be hosed.

Expected Results:  Anaconda should have installed FC4 onto the drive.

Additional info:

Core dump attached
Comment 1 Kenneth Heal 2005-08-03 08:32:21 EDT
Created attachment 117399 [details]
Core dump
Comment 2 Kenneth Heal 2005-08-03 09:12:34 EDT
Zeroing the first million sectors of the hard disk on this Fujitsu Siemens
Scenic W600 helped.  After this it appears I am able to install.  It looks like
this crash happened when the box was supposed to repartition and format the hard
disk.
Comment 3 Gerwin Krist 2005-08-04 15:44:53 EDT

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.