Bug 165067 - YUM install of kernel creates a broken link /lib/modules/2.6.12-1.1372_FC3/build
YUM install of kernel creates a broken link /lib/modules/2.6.12-1.1372_FC3/build
Status: CLOSED DUPLICATE of bug 163406
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-08-03 21:52 EDT by Bruce vanNorman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-04 00:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bruce vanNorman 2005-08-03 21:52:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
WHile trying to install nVidia twinview drivers, the nVidia "build" process failed because it could not find the kernel "source tree". It is looking for "kernel.h" which was not installed with this kernel (as  it was with 4 previous FC3 releases). The upgrade (via YUM) produced two bad links "build" and "source". I found this to be true on 4 machines - two with AMD processors and two with Intel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. "yum remove kernel-2.6.12-1.1372_FC3"
2. run "up2date" and install the above kernel
3. from root privilidge attempt with "nautilus" try to locate "/lib/modules/2.6.12-1.1372_FC3/build/include/linux/kernel.h"

Actual Results:  The "build" folder is listed as a broken link.

Expected Results:  I should have been able to drill down into "build/include/linux" and find "kernel.h"

Additional info:

I rated this bug as "high" because it renders this release unusable on my software development machine. I will continue running "kernel-2.6.11-1.27_FC3" on this machine until a repair is available. The 2.6.12-1.1327 release works on the three other machines which do not have dual-head video.
Comment 1 Dave Jones 2005-08-04 00:14:01 EDT

*** This bug has been marked as a duplicate of 163406 ***

Note You need to log in before you can comment on or make changes to this bug.