Bug 165075 - perl-DBI - Driver has not implemented the disconnect_all method
Summary: perl-DBI - Driver has not implemented the disconnect_all method
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl-DBI   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
: 165327 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-04 03:49 UTC by Michael Napolis
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 21:59:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Napolis 2005-08-04 03:49:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20040924

Description of problem:
Here is the code that generates the error on RHEL 3 U4 (perl-DBI-1.32-9) (RHEL 4 is fine, as the version of perl-DBI on RHEL 4 is newer). 
 

-

Version-Release number of selected component (if applicable):
perl-DBI-1.32-9

How reproducible:
Always

Steps to Reproduce:
-- snip -- 
 
#!/usr/bin/perl 
 
use DBI; 
 
$oracle = DBI->connect("dbi:Oracle:XXX", "xxx", "xxxxxxxx"); 
$oracle->disconnect(); 

Actual Results:  - snip -- 
 
Driver has not implemented the disconnect_all method. at /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 575 
END failed--call queue aborted.

Additional info:

Comment 1 Warren Togami 2005-09-09 02:31:15 UTC
*** Bug 165327 has been marked as a duplicate of this bug. ***

Comment 2 Jason Vas Dias 2006-03-15 21:59:03 UTC
Very sorry for the long delay in processing this bug report.

This is definitely not a bug with  perl-DBI-1.32-9, 
but could be a bug with the DBD::Oracle driver you are using.

perl-DBI-1.32-9 has no such problems connecting to a PostgreSQL database with
the DBD-Pg driver we ship:
$ perl -e 'use DBI; $pgdb=DBI->connect("dbi:Pg:dbname=xxx","xxx","");
$pgdb->disconnect();'
$ echo $?
0

So this is not a problem with the DBI module we ship - I suggest checking
that your DBD::Oracle module is up-to-date:
$ perl -MCPAN -e shell
...
cpan > install DBD::Oracle

(this should retrieve, build, test and install DBD-Oracle-1.16, currently) 
and if the problem still persists, then contact the DBD::Oracle maintainer.


Note You need to log in before you can comment on or make changes to this bug.