Bug 1650929 - Not working all bottom controls
Summary: Not working all bottom controls
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-17 17:25 UTC by Mikhail
Modified: 2019-02-08 12:47 UTC (History)
24 users (show)

Fixed In Version: mesa-19.0.0~rc2-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-08 12:31:25 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (529.61 KB, image/png)
2018-11-17 17:25 UTC, Mikhail
no flags Details

Description Mikhail 2018-11-17 17:25:56 UTC
Created attachment 1506805 [details]
screenshot

Description of problem:
In Rawhide has come mesa 18.3.0~rc2 and bottom controls in Totem player stop working again as already was described here: https://bugzilla.redhat.com/show_bug.cgi?id=1563826

Second problem is that visible area in player has incorrect size after switch player in fullscreen mode.

All the problems I tried demonstrate on attached screenshot.

$ rpm -q totem
totem-3.26.2-1.fc29.x86_64
$ totem --version
totem 3.26.2


Steps to Reproduce:
1. Open any video
2. Try rewind forward
3.

Actual results:
Buttons not works

Expected results:
All controls operable

Additional info:
- Wayland session
- AMD Vega RX 56 GPU

Comment 1 Bastien Nocera 2018-11-22 15:40:02 UTC
Was a bug in mesa, reassigning:
https://gitlab.freedesktop.org/carlosg/mesa/commit/6fe9ece4e47ddf965f8abd82f2ce58a5ce568ad8

Comment 2 Mikhail 2018-11-25 20:48:38 UTC
Bastien are you sure what it mesa bug?

As we know such problem started after AMD developers decided added 10bit support in mesa.

And Marek's position in mailing list is to keep Mesa as-is, leaving gnome-shell broken, so that gnome-shell developers are alerted and fix their code. If we react by removing 10bit support from drivers, the odds are gnome-shell will never be fixed and drivers will never be able to have 10bit support in them.

All previous Fedora versions worked only because you turned off 10bit support in mesa with patch.

I have been watching for a year how this issue going from version to version.

https://gitlab.gnome.org/GNOME/mutter/issues/2

Comment 3 Bastien Nocera 2018-11-28 13:31:36 UTC
(In reply to Mikhail from comment #2)
> Bastien are you sure what it mesa bug?

I'm not the person that reassigned it.

> As we know such problem started after AMD developers decided added 10bit
> support in mesa.

And did so in a way that broke applications it seems. In any case, there's nothing here that totem can control, and I have no hardware affected by this, so I won't be able to help.

Comment 4 Bastien Nocera 2018-12-04 12:07:35 UTC
(In reply to Mikhail from comment #2)
> Bastien are you sure what it mesa bug?
> 
> As we know such problem started after AMD developers decided added 10bit
> support in mesa.

The 10bpp support will cause problems in GNOME and with mutter indeed, but that's a completely separate bug from the controls not working, as mentioned above. The symptoms for the 10bpp support were usually that the colours were wrong, not that controls didn't work (although colour picking could be affected).

There's usually also no need to file bugs downstream if you've already filed them upstream, unless downstream is slow picking up existing patches.

The subsurface problem has a patch that's in the process of being upstreamed:
https://lists.freedesktop.org/archives/mesa-dev/2018-November/210797.html
and will shortly be in test updates for f29 and rawhide.

Comment 5 Pete Walter 2019-02-08 12:31:25 UTC
I've restored the patch in https://src.fedoraproject.org/rpms/mesa/c/a04754fe8e8c1444cc105aeb19ba778675e24bbd?branch=master . Looks like it got accidentally dropped when switching to the meson build system.

Comment 6 Mikhail 2019-02-08 12:47:54 UTC
(In reply to Pete Walter from comment #5)
> I've restored the patch in

I think it not good solution because we will never have HDR due to completely disabled rgb10.
Better to fix Totem player and I will gift my Vega 56 card to the one who will fix it.


Note You need to log in before you can comment on or make changes to this bug.