Bug 1651968 - heat test_aodh_alarm test fail
Summary: heat test_aodh_alarm test fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-heat-tests-tempest
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: z1
: 14.0 (Rocky)
Assignee: Rabi Mishra
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks: 1513902 1668560
TreeView+ depends on / blocked
 
Reported: 2018-11-21 10:30 UTC by Victor Voronkov
Modified: 2019-03-18 13:04 UTC (History)
1 user (show)

Fixed In Version: python-heat-tests-tempest-0.2.1-0.20180829061907.ecf121c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 13:04:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 619131 None None None 2018-11-21 12:27:25 UTC
Red Hat Product Errata RHBA-2019:0591 None None None 2019-03-18 13:04:16 UTC

Description Victor Voronkov 2018-11-21 10:30:55 UTC
Description of problem:

heat_tempest_plugin.tests.scenario.test_aodh_alarm using the timestamp with the timezone when creating the measures and aodh was ignoring them when evaluating the alarm

Version-Release number of selected component (if applicable):


How reproducible:
run the test

Steps to Reproduce:
[stack@undercloud-0$ . overcloudrc
(overcloud) [stack@undercloud-0$ cd /home/stack/tempest-dir
(overcloud) [stack@undercloud-0 tempest-dir]$ tempest run --regex test_aodh_alarm

Actual results:
Test fails
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/heat_tempest_plugin/tests/scenario/test_aodh_alarm.py", line 64, in test_alarm
    120, 2, self.check_instance_count, stack_identifier, 2))
  File "/usr/lib/python2.7/site-packages/unittest2/case.py", line 678, in assertTrue
    raise self.failureException(msg)
AssertionError: False is not true

Expected results:
PASS

Additional info:

Comment 5 errata-xmlrpc 2019-03-18 13:04:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0591


Note You need to log in before you can comment on or make changes to this bug.