Bug 1652118 - default cluster.max-bricks-per-process to 250
Summary: default cluster.max-bricks-per-process to 250
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1653073 1653136
TreeView+ depends on / blocked
 
Reported: 2018-11-21 15:48 UTC by Atin Mukherjee
Modified: 2019-03-25 16:32 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1653073 (view as bug list)
Environment:
Last Closed: 2019-03-25 16:32:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21701 None Merged glusterd: make max-bricks-per-process default value to 250 2018-11-25 14:34:32 UTC
Gluster.org Gerrit 21797 None Merged glusterd: set cluster.max-bricks-per-process to 250 2018-12-05 07:52:43 UTC

Description Atin Mukherjee 2018-11-21 15:48:16 UTC
Description of problem:

In a scale container storage setup which hosts ~1000 1 X 3 volumes, its seen that if a single brick process is going to host all the rest of 999 brick instances, the overall footprint of the brick process might still be at the higher side. We already have an option cluster.max-bricks-per-process which when set to a value n, that's the max cap of number of brick instances to be attached to a brick process. We have seen benefits in defining a cap of 250 of bricks per process in few scale deployments where things haven't gone crazy like glusterd taking lots of time to process disconnect events, bricks not reaching to a warning level of OOM killer situation etc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-11-21 15:50:14 UTC
REVIEW: https://review.gluster.org/21701 (glusterd: make max-bricks-per-process default value to 250) posted (#1) for review on master by Atin Mukherjee

Comment 2 Worker Ant 2018-11-25 14:34:31 UTC
REVIEW: https://review.gluster.org/21701 (glusterd: make max-bricks-per-process default value to 250) posted (#2) for review on master by Atin Mukherjee

Comment 3 Worker Ant 2018-12-04 13:55:28 UTC
REVIEW: https://review.gluster.org/21797 (glusterd: set cluster.max-bricks-per-process to 250) posted (#1) for review on master by Atin Mukherjee

Comment 4 Worker Ant 2018-12-05 07:52:42 UTC
REVIEW: https://review.gluster.org/21797 (glusterd: set cluster.max-bricks-per-process to 250) posted (#2) for review on master by Atin Mukherjee

Comment 5 Shyamsundar 2019-03-25 16:32:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.