Bug 1653073 - default cluster.max-bricks-per-process to 250
Summary: default cluster.max-bricks-per-process to 250
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.4.z Batch Update 2
Assignee: Atin Mukherjee
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On: 1652118
Blocks: 1653136
TreeView+ depends on / blocked
 
Reported: 2018-11-25 14:35 UTC by Atin Mukherjee
Modified: 2018-12-18 07:27 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.12.2-31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1652118
: 1653136 (view as bug list)
Environment:
Last Closed: 2018-12-17 17:07:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21701 None None None 2018-11-25 14:35:45 UTC
Red Hat Product Errata RHBA-2018:3827 None None None 2018-12-17 17:07:35 UTC

Description Atin Mukherjee 2018-11-25 14:35:45 UTC
+++ This bug was initially created as a clone of Bug #1652118 +++

Description of problem:

In a scale container storage setup which hosts ~1000 1 X 3 volumes, its seen that if a single brick process is going to host all the rest of 999 brick instances, the overall footprint of the brick process might still be at the higher side. We already have an option cluster.max-bricks-per-process which when set to a value n, that's the max cap of number of brick instances to be attached to a brick process. We have seen benefits in defining a cap of 250 of bricks per process in few scale deployments where things haven't gone crazy like glusterd taking lots of time to process disconnect events, bricks not reaching to a warning level of OOM killer situation etc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-11-21 10:50:14 EST ---

REVIEW: https://review.gluster.org/21701 (glusterd: make max-bricks-per-process default value to 250) posted (#1) for review on master by Atin Mukherjee

--- Additional comment from Worker Ant on 2018-11-25 09:34:31 EST ---

REVIEW: https://review.gluster.org/21701 (glusterd: make max-bricks-per-process default value to 250) posted (#2) for review on master by Atin Mukherjee

Comment 16 errata-xmlrpc 2018-12-17 17:07:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3827


Note You need to log in before you can comment on or make changes to this bug.