Bug 1652419 - Missing service broker operator image
Summary: Missing service broker operator image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks: 1660890
TreeView+ depends on / blocked
 
Reported: 2018-11-22 03:19 UTC by Zihan Tang
Modified: 2019-06-04 10:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1660890 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:41:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:08 UTC

Description Zihan Tang 2018-11-22 03:19:18 UTC
Description of problem:
Missing the follow images for downstream test:
openshift/ose-template-service-broker-operator:v4.0
openshift/ose-automation-broker-operator:v4.0 


Version-Release number of selected component (if applicable):
openshift v4.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zihan Tang 2018-11-26 09:12:03 UTC
Because we are starting regression test in 'Next-Gen Installer' env, tsb&asb operator images are not ready in downstream, so add `TestBlocker` tag to trace.

Comment 4 Zihan Tang 2018-12-19 07:48:44 UTC
I saw asb and tsb operator image is exist on brew registry, but not exist in reg-aws registry, can you help push the them to reg-aws registry?

Comment 5 Jason Montleon 2018-12-19 13:41:09 UTC
I'm not sure if they need to become a part of the puddles in order for that to happen. We're working on it. I'll be submitting PR's to add the downstream Dockerfiles and creating the individual requests using the ART template today.

Comment 6 Jason Montleon 2018-12-19 14:31:33 UTC
We're also still missing ansible-runner-http downstream as far as I can see so these images likely won't work anyway.

Comment 8 Zihan Tang 2018-12-20 08:07:09 UTC
We'll upstream image for pre-test, remove testblocker keywords.

Comment 9 Zihan Tang 2019-02-12 09:43:49 UTC
In the lastes build: registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-02-12-005016, still no asb and tsb operators:
checking by command: 
oc adm release info --pullspecs "registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-02-12-005016"

Comment 10 Zhang Cheng 2019-02-12 10:03:15 UTC
Adding TestBlocker and beta2blocker since broker operators should be ship in beta 2 release.

Comment 16 Jason Montleon 2019-02-14 13:36:05 UTC
Can you check the other registries again for the TSB operator? From what I was hearing the sync may have just not happened yet.

Comment 19 Zihan Tang 2019-02-18 03:31:53 UTC
(In reply to Jason Montleon from comment #17)
> ansible-service-broker-operator should be available now as well. Please let
> us know if the images are available on the registries you expect or if
> something is still preventing you from starting to test these. Thanks!
> 
We can get operator images from downstream registry, remove TestBlocker.

For other cluster operators we get from registry.svc.ci.openshift.org or origin-release.svc.ci.openshift.org.
But I'm not exactly sure which registry the 2 operators SHOULD be placed. 

This may be confirmed with ART team or Release team.

Comment 20 Jason Montleon 2019-02-18 15:39:24 UTC
Tim, could you help us understand if we need additional setup to see these images on these registries?

Comment 22 Zihan Tang 2019-02-21 10:14:20 UTC
Thanks Luke.

Jason, 
how can we use the downstream image?
payload in marketplace can not be changed, it still using docker.io/automationbroker/automation-broker-operator:v4.0

the ansible-playbook also using docker.io/automationbroker/automation-broker-operator:v4.0 
can you fix the payload in marketplace or seperate to use 2 operators(tsb-operator or asb-operator) and so that we can replace them as workaround ?

Comment 23 Shawn Hurley 2019-02-21 15:01:46 UTC
@Jason - I think if we are starting to talk about how to test then all the images are downstream and it is on us to figure out how to test.

@Zihan - your correct that this is a problem. I have been working on a solution. Basically, the problem is that we will have to bypass OperatorHub and create our own catalog source for the Broker built with its image and different version of the operator-registry. I will put a doc together today or tomorrow. I believe that there is probably an OperatorHub or OLM bug/feature here that is the underlying cause. Do you think that we could open a bug to track and we can close this out with the workaround?

Comment 25 Zihan Tang 2019-02-25 09:40:44 UTC
For downstream image, we still need ways to using the 2 downstream images through marketplace or other workaround which is the last step to verify this bug. 
Move to Modified.

Comment 27 Zhang Cheng 2019-02-26 06:29:15 UTC
Changing status to Assign since we are still waiting the clarification and downstream images are not ready for test.
Please refer to comment 22 and comment 24. Thanks.

Comment 28 Shawn Hurley 2019-03-04 20:56:09 UTC
This PR is needed: https://github.com/openshift/ansible-service-broker/pull/1187

To use this Dockerfile:

create a new image from the operator directory. Here is where you can use the build-args for the downstream images. There is no default so you have to enter both to get a build that will work. Example:

$ docker build -t quay.io/shawn_hurley/testing-downstream-catalog-source -f build/olm-testing.Dockerfile --build-arg operator_name=quay.io/shawn_hurley/abo:v4.0 --build-arg broker_name=quay.io/shawn_hurley/ab:v4.0 .

Run this image as a catalog source by creating this resource:

apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  name: abo-registry
  namespace: openshift-operator-lifecycle-manager
spec:
  sourceType: grpc
  image: quay.io/shawn_hurley/testing-downstream-catalog-source
Then follow the same UI steps to install the automation-broker-operator and automation-broker which should use the images that you changed.

NOTE: This is only for testing.

Comment 29 Shawn Hurley 2019-03-04 21:07:53 UTC
Please note that the downstream process is still being worked on for these images. This is not something that we can change, and I don't think keeping this bug open is worth tracking that IMO. Up to you guys though.

Comment 30 Zihan Tang 2019-03-05 06:46:17 UTC
thanks for your workaround create downstream image for testing.

where should we release tsb/asb operators and link to marketplace? 
For other community operators, they temporarily use 'quay.io' for operator image which by default linked to marketplace. 
I'll clone a bug for this.

Comment 33 errata-xmlrpc 2019-06-04 10:41:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.