Bug 1652453 - Master has a duplicate domain name
Summary: Master has a duplicate domain name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Luis Tomas Bolivar
QA Contact: Udi Shkalim
URL:
Whiteboard:
: 1656061 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 07:07 UTC by Itzik Brown
Modified: 2019-01-10 09:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-10 09:04:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
all.yml (1.74 KB, text/x-vhdl)
2018-11-22 07:07 UTC, Itzik Brown
no flags Details
OSEv3.yml (876 bytes, text/x-vhdl)
2018-11-22 07:08 UTC, Itzik Brown
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-ansible pull 10861 None closed [release-3.11] Fix openstack nsupdate record 2020-05-19 14:31:56 UTC
Red Hat Product Errata RHBA-2019:0024 None None None 2019-01-10 09:05:49 UTC

Description Itzik Brown 2018-11-22 07:07:41 UTC
Created attachment 1507883 [details]
all.yml

Description of problem:
After installation of OpenShift on Openstack the master has a duplicate domain name in .kube/config and when getting the project name

[stack@undercloud-0 ~]$ grep master ~/.kube/config  
    server: https://master-0.openshift.example.com.openshift.example.com:8443
  name: master-0-openshift-example-com-openshift-example-com:8443
    user: system:admin/master-0-openshift-example-com-openshift-example-com:8443
    cluster: master-0-openshift-example-com-openshift-example-com:8443
    user: system:admin/master-0-openshift-example-com-openshift-example-com:8443
  name: default/master-0-openshift-example-com-openshift-example-com:8443/system:admin
current-context: default/master-0-openshift-example-com-openshift-example-com:8443/system:admin
- name: system:admin/master-0-openshift-example-com-openshift-example-com:8443
[stack@undercloud-0 ~]$ 
[stack@undercloud-0 ~]$ oc project
Using project "default" on server "https://master-0.openshift.example.com.openshift.example.com:8443".


Version-Release number of the following components:
openshift-ansible-3.11.44-1.git.0.11d174e.el7.noarch
ansible-2.6.7-1.el7ae.noarch
ansible 2.6.7
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/home/cloud-user/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Sep 12 2018, 05:31:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-36)]

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Itzik Brown 2018-11-22 07:08:26 UTC
Created attachment 1507884 [details]
OSEv3.yml

Comment 2 Scott Dodson 2018-11-26 14:58:56 UTC
Can you elaborate on the problem you're facing? What's actually broken or doesn't work as you'd expect? Please provide `oc config view` output

Comment 3 Itzik Brown 2018-12-02 06:57:03 UTC
Output of 'oc config view'

apiVersion: v1
clusters:
- cluster:
    certificate-authority-data: REDACTED
    server: https://console.openshift.example.com:8443
  name: console-openshift-example-com:8443
- cluster:
    certificate-authority-data: REDACTED
    server: https://master-0.openshift.example.com.openshift.example.com:8443
  name: master-0-openshift-example-com-openshift-example-com:8443
contexts:
- context:
    cluster: console-openshift-example-com:8443
    namespace: default
    user: system:admin/master-0-openshift-example-com-openshift-example-com:8443
  name: default/console-openshift-example-com:8443/system:admin
- context:
    cluster: master-0-openshift-example-com-openshift-example-com:8443
    namespace: default
    user: system:admin/master-0-openshift-example-com-openshift-example-com:8443
  name: default/master-0-openshift-example-com-openshift-example-com:8443/system:admin
current-context: default/master-0-openshift-example-com-openshift-example-com:8443/system:admin
kind: Config
preferences: {}
users:
- name: system:admin/master-0-openshift-example-com-openshift-example-com:8443
  user:
    client-certificate-data: REDACTED
    client-key-data: REDACTED

Comment 4 Luis Tomas Bolivar 2018-12-11 13:06:41 UTC
*** Bug 1656061 has been marked as a duplicate of this bug. ***

Comment 6 Udi Shkalim 2018-12-27 10:30:38 UTC
Verified fix on 3.11

[root@master-0 ~]# hostname -A
master-0.openshift.example.com master-0.openshift.example.com

[root@master-0 ~]# hostname -f
master-0.openshift.example.com

[root@master-0 ~]# grep console .kube/config
    server: https://console.openshift.example.com:8443
  name: console-openshift-example-com:8443
    cluster: console-openshift-example-com:8443
    user: system:admin/console-openshift-example-com:8443
  name: default/console-openshift-example-com:8443/system:admin
current-context: default/console-openshift-example-com:8443/system:admin
- name: system:admin/console-openshift-example-com:8443

Comment 8 errata-xmlrpc 2019-01-10 09:04:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0024


Note You need to log in before you can comment on or make changes to this bug.