Bug 1656061
| Summary: | Heat stack failed to delete - need to remove router's subnet ports before trying to remove the subnet | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Udi Shkalim <ushkalim> |
| Component: | Installer | Assignee: | Luis Tomas Bolivar <ltomasbo> |
| Installer sub component: | openshift-ansible | QA Contact: | Udi Shkalim <ushkalim> |
| Status: | CLOSED DUPLICATE | Docs Contact: | |
| Severity: | high | ||
| Priority: | high | CC: | ltomasbo, mburns, sbaker, shardy, ushkalim |
| Version: | 3.11.0 | Keywords: | Triaged |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | All | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-12-11 13:06:41 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Udi Shkalim
2018-12-04 15:04:58 UTC
@Udi: Did you try to remove the stack with 'openstack stack delete ...'? Is this deployment using Kuryr? The right way to remove the stack installed with openshift-ansible playbooks is to also use the provided uninstall playbook. Note there are several resources created by Kuryr (for instance subnets for the namespaces) that were not created by the initial heat template, so stack delete will fail to delete those (as it is not aware of them) (In reply to Luis Tomas Bolivar from comment #2) > @Udi: Did you try to remove the stack with 'openstack stack delete ...'? Is > this deployment using Kuryr? The right way to remove the stack installed > with openshift-ansible playbooks is to also use the provided uninstall > playbook. Note there are several resources created by Kuryr (for instance > subnets for the namespaces) that were not created by the initial heat > template, so stack delete will fail to delete those (as it is not aware of > them) Thanks for the information. Yes the deployment is using kuryr. I'm running the uninstall playbook. Then, I don't think this belongs to heat, but to openshift-ansible uninstall playbook It would be great to have information about the resources that were not deleted with the uninstall playbook, and the tasks that failed (if any) It was an openshift-ansible issue that was resolved by - https://github.com/openshift/openshift-ansible/commit/e8727c80edf9dd056e42d8b705235e46e480ec1a Should we keep it for downstream tracking? We cherry-picked this patch to our infrared openshift plugin - https://code.engineering.redhat.com/gerrit/#/c/158044/ Should we backport it to ansible 3.11/10 as well? The problem of the double domain name is covered on this bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1652453 So, I'm closing this one as a duplicate of it *** This bug has been marked as a duplicate of bug 1652453 *** |