Bug 1652459 - vlan interface doesn't exists once network target reached
Summary: vlan interface doesn't exists once network target reached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: radvd
Version: 28
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1653658
TreeView+ depends on / blocked
 
Reported: 2018-11-22 07:27 UTC by Ben Herrick
Modified: 2019-02-12 01:26 UTC (History)
16 users (show)

Fixed In Version: radvd-2.17-16.fc29 radvd-2.17-12.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1653658 (view as bug list)
Environment:
Last Closed: 2018-11-29 04:58:21 UTC


Attachments (Terms of Use)

Description Ben Herrick 2018-11-22 07:27:18 UTC
Description of problem:
When configured to serve VLAN interfaces, the radvd unit fails to start at boot.


Version-Release number of selected component (if applicable):
radvd-2.17-10.fc28.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Configure radvd to advertise on VLAN interfaces.
2. Reboot.
3. Watch radvd fail to start.

Actual results:
Failed unit startup.

Expected results:
Running radvd.service unit.

Additional info:

Comment 1 Ben Herrick 2018-11-22 07:28:54 UTC
From journalctl:

Nov 18 14:55:30 xxxx radvd[1191]: version 2.17 started
Nov 18 14:55:30 xxxx radvd[1191]: IPv6 forwarding setting is: 0, should be 1 or 2
Nov 18 14:55:30 xxxx radvd[1191]: IPv6 forwarding seems to be disabled, but continuing anyway
Nov 18 14:55:30 xxxx radvd[1194]: enp2s0.254 not found: No such device

Comment 2 Pavel Zhukov 2018-11-22 11:05:46 UTC
Hello,

Thank you for the bug report.
It's weird nobody was noticed before. The fix is simple one line patch. I'll submit it upstream

Comment 3 Pavel Zhukov 2018-11-26 15:06:45 UTC
it's weird I've checked version in rawhide and it works fine. 

#without vlan device:

Nov 26 16:02:45 pzhukov-x240.example.com systemd[1]: Starting Router advertisement daemon for IPv6...
Nov 26 16:02:45 pzhukov-x240.example.com radvd[10087]: version 2.17 started
Nov 26 16:02:45 pzhukov-x240.example.com radvd[10087]: IPv6 forwarding setting is: 0, should be 1 or 2
Nov 26 16:02:45 pzhukov-x240.example.com radvd[10087]: IPv6 forwarding seems to be disabled, but continuing anyway
Nov 26 16:02:45 pzhukov-x240.example.com systemd[1]: Started Router advertisement daemon for IPv6.
Nov 26 16:02:45 pzhukov-x240.example.com radvd[10088]: enp0s25.100 not found: No such device


# sudo ip link add link enp0s25 name enp0s25.100 type vlan id 100

# with vlan device
-- Logs begin at Mon 2018-11-19 10:50:53 CET, end at Mon 2018-11-26 15:57:22 CET. --
Nov 26 15:57:14 pzhukov-x240.example.com systemd[1]: Starting Router advertisement daemon for IPv6...
Nov 26 15:57:14 pzhukov-x240.example.com radvd[9677]: version 2.17 started
Nov 26 15:57:14 pzhukov-x240.example.com radvd[9677]: IPv6 forwarding setting is: 0, should be 1 or 2
Nov 26 15:57:14 pzhukov-x240.example.com radvd[9677]: IPv6 forwarding seems to be disabled, but continuing anyway
Nov 26 15:57:14 pzhukov-x240.example.com systemd[1]: Started Router advertisement daemon for IPv6.


# radvd.conf
interface enp0s25.100
{
// omitted

};

There were not too many changes between f28 and rawhide
Can you please double check your config? 


+* Wed Jun 13 2018 Pavel Zhukov <pzhukov@redhat.com> - 2.17-14
+- Log to stderr in non-daemon mode
+- Add nodaemon option into manpage
+- Re-enable test again
+
+* Mon Jun 04 2018 Pavel Zhukov <pzhukov@redhat.com> - 2.17-12
+- Enable tests and fix them on big endian arches
+
+* Thu Apr 12 2018 Pavel Zhukov <pzhukov@redhat.com> - 2.17-11
+- Enable Werror=all

Comment 4 Ben Herrick 2018-11-27 03:16:18 UTC
Try adding the VLAN interface using nmcli and then reboot.

The problem does not occur when starting radvd after the system is booted, but radvd will fail because the VLAN interfaces are started _AFTER_ radvd.

Comment 5 Ben Herrick 2018-11-27 03:19:54 UTC
To be clear, you have to add the VLAN interface permanently in nmcli, also add the configuration for the prefix/interface in /etc/radvd.conf and then reboot in order to observe the behavior.

Comment 6 Pavel Zhukov 2018-11-27 07:52:42 UTC
(In reply to Ben Herrick from comment #4)
> Try adding the VLAN interface using nmcli and then reboot.
> 
> The problem does not occur when starting radvd after the system is booted,
> but radvd will fail because the VLAN interfaces are started _AFTER_ radvd.

It's different problem and seems like radvd has nothing to do with it but NM brings vlan interface up too late.

[Unit]
Description=Router advertisement daemon for IPv6
After=network.target

Comment 7 Beniamino Galvani 2018-11-27 08:27:20 UTC
If radvd needs that all connection profiles are activated when it's started, it should depend on the network-online.target in this way:

 After=network-online.target
 Wants=network-online.target

so that it is delayed until NetworkManager has completed the initialization. The NetworkManager-wait-online.service should be active as well.

Comment 8 Pavel Zhukov 2018-11-27 08:50:47 UTC
(In reply to Beniamino Galvani from comment #7)
> If radvd needs that all connection profiles are activated when it's started,
> it should depend on the network-online.target in this way:
> 
>  After=network-online.target
>  Wants=network-online.target
> 
> so that it is delayed until NetworkManager has completed the initialization.
> The NetworkManager-wait-online.service should be active as well.

Ok. Thanks. Moving back then.
Sorry for the noise

Comment 9 Pavel Zhukov 2018-11-27 08:51:08 UTC
(In reply to Beniamino Galvani from comment #7)
> If radvd needs that all connection profiles are activated when it's started,
> it should depend on the network-online.target in this way:
> 
>  After=network-online.target
>  Wants=network-online.target
> 
> so that it is delayed until NetworkManager has completed the initialization.
> The NetworkManager-wait-online.service should be active as well.

Ok. Thanks. Moving back then.
Sorry for the noise

Comment 10 Fedora Update System 2018-11-27 11:15:55 UTC
radvd-2.17-11.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3222e7c914

Comment 11 Fedora Update System 2018-11-27 11:16:37 UTC
radvd-2.17-16.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b333ac9645

Comment 12 Fedora Update System 2018-11-28 03:47:27 UTC
radvd-2.17-11.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3222e7c914

Comment 13 Fedora Update System 2018-11-28 04:51:28 UTC
radvd-2.17-16.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b333ac9645

Comment 14 Fedora Update System 2018-11-29 04:58:21 UTC
radvd-2.17-16.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-01-27 19:51:37 UTC
radvd-2.17-12.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-333a7aa511

Comment 16 Fedora Update System 2019-01-28 01:02:33 UTC
radvd-2.17-12.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-333a7aa511

Comment 17 Fedora Update System 2019-02-12 01:26:10 UTC
radvd-2.17-12.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.