Bug 1652801 - [abrt] xfwm4: g_log_structured_standard(): xfwm4 killed by SIGTRAP
Summary: [abrt] xfwm4: g_log_structured_standard(): xfwm4 killed by SIGTRAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfwm4
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9c1ca548dc249cc3089b7ab7960...
: 1657488 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 04:51 UTC by Sam Varshavchik
Modified: 2019-05-03 21:24 UTC (History)
6 users (show)

Fixed In Version: xfwm4-4.13.1-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 05:29:22 UTC


Attachments (Terms of Use)
File: backtrace (54.24 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: cgroup (349 bytes, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: core_backtrace (10.58 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: cpuinfo (1.15 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: dso_list (8.73 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: environ (3.90 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: limits (1.29 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: maps (58.17 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: mountinfo (3.55 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: open_fds (725 bytes, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details
File: proc_pid_status (1.31 KB, text/plain)
2018-11-23 04:51 UTC, Sam Varshavchik
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 14899 None None None 2019-06-10 15:33:40 UTC

Description Sam Varshavchik 2018-11-23 04:51:21 UTC
Description of problem:
Hitting Alt-Tab when some window on the desktop is shaded always results in this crash.

Version-Release number of selected component:
xfwm4-4.13.1-3.fc29

Additional info:
reporter:       libreport-2.9.6
backtrace_rating: 4
cmdline:        xfwm4 --display :0.0 --sm-client-id 22c65bcb1-bd44-4633-ab3a-1d4afc944622
crash_function: g_log_structured_standard
executable:     /usr/bin/xfwm4
journald_cursor: s=a6cea96bc93547a384bf9640be65a365;i=3fa15;b=a27f28fda77b4ae8b1a133b072e45035;m=c1f5a35f1;t=57b4d545700ff;x=e0c89d811d48438
kernel:         4.18.18-300.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Sam Varshavchik 2018-11-23 04:51:26 UTC
Created attachment 1508195 [details]
File: backtrace

Comment 2 Sam Varshavchik 2018-11-23 04:51:27 UTC
Created attachment 1508196 [details]
File: cgroup

Comment 3 Sam Varshavchik 2018-11-23 04:51:29 UTC
Created attachment 1508197 [details]
File: core_backtrace

Comment 4 Sam Varshavchik 2018-11-23 04:51:30 UTC
Created attachment 1508198 [details]
File: cpuinfo

Comment 5 Sam Varshavchik 2018-11-23 04:51:31 UTC
Created attachment 1508199 [details]
File: dso_list

Comment 6 Sam Varshavchik 2018-11-23 04:51:32 UTC
Created attachment 1508200 [details]
File: environ

Comment 7 Sam Varshavchik 2018-11-23 04:51:33 UTC
Created attachment 1508201 [details]
File: limits

Comment 8 Sam Varshavchik 2018-11-23 04:51:35 UTC
Created attachment 1508202 [details]
File: maps

Comment 9 Sam Varshavchik 2018-11-23 04:51:36 UTC
Created attachment 1508203 [details]
File: mountinfo

Comment 10 Sam Varshavchik 2018-11-23 04:51:37 UTC
Created attachment 1508204 [details]
File: open_fds

Comment 11 Sam Varshavchik 2018-11-23 04:51:38 UTC
Created attachment 1508205 [details]
File: proc_pid_status

Comment 12 Kevin Fenzi 2018-11-23 19:28:31 UTC
Excellent detective work. Would you be willing to file this upstream at bugzilla.xfce.org? Or would you prefer I do so?

Comment 13 Sam Varshavchik 2018-11-23 20:10:26 UTC
https://bugzilla.xfce.org/show_bug.cgi?id=14899

Comment 14 Kevin Fenzi 2018-11-24 05:49:36 UTC
Thanks!

Comment 15 Raphael Groner 2018-12-10 23:25:43 UTC
*** Bug 1657488 has been marked as a duplicate of this bug. ***

Comment 16 Raphael Groner 2018-12-10 23:26:36 UTC
Close this with reason upstream?

(In reply to Raphael Groner from comment #15)
> *** Bug 1657488 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2018-12-20 14:26:13 UTC
xfwm4-4.13.1-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f7ef40aa0f

Comment 18 Fedora Update System 2018-12-21 21:06:06 UTC
xfwm4-4.13.1-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f7ef40aa0f

Comment 19 Fedora Update System 2019-01-03 05:29:22 UTC
xfwm4-4.13.1-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 João Carlos Mendes Luís 2019-05-03 21:24:25 UTC
Happened again in fc30?

#1706243


Note You need to log in before you can comment on or make changes to this bug.