Bug 165290 - missing kernel source for nVidia twinview
missing kernel source for nVidia twinview
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 00:00 EDT by Bruce vanNorman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 14:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce vanNorman 2005-08-07 00:00:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
the links to the kernel source (kernel.h) are broken so I cannot install nVidia's twinview. See bug #163406 which is the same error as applies to FC3.
---
At the risk of ranting - if I am to continue Linux development, I require nVidia Twinview (dual head support). The nVidia PKG requires access to kernel.h to install. Note: I don't care about HP printers, although somebody else does. I am not unsympathetic. As things stand, neither FC3 nor FC4 are usable for my intended purpose. I no longer run Linux. I am limited to Windows (nVidia's nView for dual head support) for all my development efforts :-(
---
Why all this attachment to dual head for development? It is a question of screen real-estate for editors, profilers, debuggers, IDE's, and the application under construction. I have two Samsung SyncMaster 171N ultra thin bezel LCD displays (1280 x 1024) clamped togeterh on a VESA 100 dual display bracket. Getting all those pixels and area on a single monitor is way beyond my budget.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1369-FC4 & 1.1398-FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 from CD's
2. use nautilus to follow the links
3.
  

Actual Results:  the link(s) /lib/modules/2.6.12-1.1369 (and 1398) -FC4/build are broken

Expected Results:  the links beyound ..../build should exist.
There should be some way to find kernel.h for the running kernel.

Additional info:

link is broken on 4 machines running FC4 and FC3.
Re severity. I would rate this problem as most serious (not "normal") because it renders the distributions as usless as "data loss", "serious memory leak", would.
Comment 1 Gerwin Krist 2005-08-07 14:52:37 EDT
What software are you refering too? I installed nvidia stuff without problems,
so please tell me where you get the problem with? Links are not brken at my
place as long as you have the kernel-devel package installed.
Please react on this one mail, else I will put it on "WORKSFORME"

Cheers!
Comment 2 Warren Togami 2005-08-08 15:10:29 EDT
Install kernel-devel.
Comment 3 Bruce vanNorman 2005-08-08 21:43:03 EDT
Works on my machine too :-) Now.
- The bug description should be corrected to "kernel-devel package gets dropped
when upgrading to FC4". The condition reported in 165067/163406 is prerequisite.
The kernel-devel package was installed by the FC3 CD distribution and correctly
maintained through 3 FC3 kernel upgrades until the situation reported in 165067
occured. Thanks for the help. Iv'e been a sysgen soldier (os/390 and VM/CMS -
also IBM mainframe) for over 30 years. Your care, attentivness and expertise are
first rate.
Comment 4 Dave Jones 2005-08-09 14:54:04 EDT
there is no kernel-devel package in FC3, so nothing got dropped.
It just isn't installed by default, as its not something that every user needs.

Note You need to log in before you can comment on or make changes to this bug.