Bug 1652973 - Add libgnome-keyring as dependency [NEEDINFO]
Summary: Add libgnome-keyring as dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nextcloud-client
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1665728 1669590 1674106 1754003 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 19:09 UTC by Julian Hofer
Modified: 2020-05-06 05:07 UTC (History)
15 users (show)

Fixed In Version: nextcloud-client-2.6.4-4.fc32 nextcloud-client-2.6.4-4.fc31 nextcloud-client-2.6.4-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-01 00:36:28 UTC
Type: Bug
redhat: needinfo? (extras-qa)


Attachments (Terms of Use)

Description Julian Hofer 2018-11-23 19:09:20 UTC
Description of problem:
When starting nextcloud, after reboot, there is a dialog to enter the password with the message: No keychain service available

Version-Release number of selected component (if applicable):
2.3.3

How reproducible:
The dialog pops up after every reboot

Steps to Reproduce:
1.Reboot

Actual results:
Dialog to input password pops up

Expected results:
The password should be stored

Additional info:
Problem can be fixed by installing "sudo dnf install libgnome-keyring"

Comment 1 Germano Massullo 2019-01-09 16:37:37 UTC
from #fedora-devel: most apps have migrated from old libgnome-keyring to newer libsecret, that's why it's no longer installed as default

Moreover, as stated in 
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892359
The libgnome-keyring library is deprecated and its usage is strongly discouraged [2].

Waiting for upstream to implement libsecret usage.


[2] https://git.gnome.org/browse/libgnome-keyring/commit/?id=6a5adea4aec93

Comment 2 Germano Massullo 2019-01-14 09:35:23 UTC
*** Bug 1665728 has been marked as a duplicate of this bug. ***

Comment 3 Eric Lavarde 2019-01-14 10:29:27 UTC
I don't think that the issue is actually closed because the problem is still there until the software uses and the package depends on libsecret, but anyway, I've referenced this bug towards https://github.com/nextcloud/desktop/issues/990 and https://github.com/nextcloud/desktop/issues/883 - hopefully we'll get sooner than later an upstream fix of the issue.

Comment 4 Germano Massullo 2019-10-04 13:29:27 UTC
*** Bug 1669590 has been marked as a duplicate of this bug. ***

Comment 5 Germano Massullo 2019-10-04 13:29:31 UTC
*** Bug 1674106 has been marked as a duplicate of this bug. ***

Comment 6 Germano Massullo 2019-11-13 18:54:10 UTC
*** Bug 1754003 has been marked as a duplicate of this bug. ***

Comment 7 IanB 2020-01-02 07:27:30 UTC
I just hit this issue on Fedora 31. My reading of the upstream issue: https://github.com/nextcloud/desktop/issues/427 is that the problem is due to qtkeychain-qt5 (nextcloud-client dependency) missing support for libsecret. I'm out of my depth here, so could be talking nonsense!

Comment 8 Eric Lavarde 2020-01-16 07:44:11 UTC
IMHO the problem is still there because the nextcloud-client package still doesn't depend on libsecret. Install libsecret and the issue is gone.

Comment 9 Laurenz Grote 2020-04-01 13:26:53 UTC
The issue is still present. Installing libgnome-keyring manually is still a quick fix. Can't libgnome-keyring be added as a dependency until upstream uses libsecret?

Comment 10 Christian Kujau 2020-04-27 17:48:46 UTC
Indeed, [this](https://help.nextcloud.com/t/fedora-30-nextcloud-client-issues-does-not-preserve-login-after-user-account-logout-or-reboot/56770/3 "Fedora 30 Nextcloud client issues — does not preserve login after user account logout or reboot") is still an issue with F31. Apparently the nextcloud client is kinda QT5-centric and does not seem to include any Gnome libraries at all:


------------------------------------------------------------------------
$ dnf deplist `rpm -qa | grep nextcloud` | egrep -i '^package|key|gnome|^$'
package: nextcloud-client-2.6.4-3.fc31.x86_64
  dependency: libqt5keychain.so.1()(64bit)
   provider: qtkeychain-qt5-0.9.1-3.fc31.x86_64

package: nextcloud-client-libs-2.6.4-3.fc31.x86_64
  dependency: libqt5keychain.so.1()(64bit)
   provider: qtkeychain-qt5-0.9.1-3.fc31.x86_64

package: nextcloud-client-nautilus-2.6.4-3.fc31.x86_64
------------------------------------------------------------------------

Can this bug be re-opened or shall we open a new report?

Comment 11 Fedora Update System 2020-04-27 18:21:49 UTC
FEDORA-2020-3532b01b96 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3532b01b96

Comment 12 Fedora Update System 2020-04-27 18:21:50 UTC
FEDORA-2020-55ce43f6c4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-55ce43f6c4

Comment 13 Fedora Update System 2020-04-27 18:21:50 UTC
FEDORA-2020-973ee8680b has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-973ee8680b

Comment 14 Germano Massullo 2020-04-27 18:22:31 UTC
Please test the just submitted new testing updates and leave a karma feedback
Thank you

Comment 15 Germano Massullo 2020-04-27 18:23:23 UTC
*** Bug 1791915 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2020-04-28 03:24:04 UTC
FEDORA-2020-973ee8680b has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-973ee8680b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-973ee8680b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2020-04-28 03:46:09 UTC
FEDORA-2020-55ce43f6c4 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-55ce43f6c4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-55ce43f6c4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2020-04-28 03:52:16 UTC
FEDORA-2020-3532b01b96 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3532b01b96`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3532b01b96

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2020-05-01 00:36:28 UTC
FEDORA-2020-973ee8680b has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-05-06 03:07:41 UTC
FEDORA-2020-3532b01b96 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2020-05-06 05:07:42 UTC
FEDORA-2020-55ce43f6c4 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.