Bug 1674106 - Add libgnome-keyring to REQUIRES secton of nextcloud-client package
Summary: Add libgnome-keyring to REQUIRES secton of nextcloud-client package
Keywords:
Status: CLOSED DUPLICATE of bug 1652973
Alias: None
Product: Fedora
Classification: Fedora
Component: nextcloud-client
Version: 29
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1685212 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-09 08:20 UTC by Milan Zink
Modified: 2019-10-04 13:29 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-04 13:29:31 UTC


Attachments (Terms of Use)

Description Milan Zink 2019-02-09 08:20:17 UTC
Description of problem:

Nextcloud client is experiencing problems with connecting to gnome-keyring. User is asked for password on each app startup. Described here https://github.com/owncloud/client/issues/6500 (Ubuntu & owncloud, but the same issues on Fedora & nextcloud) 


Version-Release number of selected component (if applicable):
nextcloud-client-2.5.1-1.fc29.x86_64 (updates-testing)
also tested on 2.3.3 (stable)


How reproducible:
* make sure libgnome-keyring is not installed
* install nextloud-client
* start app and login to nexcloud
* quit client
* start client again, you'll be asked for login and password again


Steps to Reproduce:
1. see above
2. can be fixed by installing libgnome-keyring and logout/login.


Actual results:
You've been logged out. Error message: `No keychain service available`

Expected results:
Credentials retrieved from keyring service. User not prompted for login each time app starts


Additional info:
Problem solved by installing libgnome-keyring package. I believe it should be added to REQUIRES section of nextcloud-client package.

Comment 1 rugk 2019-05-01 19:35:07 UTC
*** Bug 1685212 has been marked as a duplicate of this bug. ***

Comment 2 rugk 2019-05-01 19:37:42 UTC
I reported the same issue in Bug 1685212 as a dupe.

I wonder why no one has reacted so far!

This is a big UX issue, as users, who do not dig into why Nextcloud cannot remember their credentials will not notice it and possibly re-enter their password again and again…
Or just uninstall the Nextcloud client and blame… either Nextcloud or Fedora…

Comment 3 rugk 2019-05-01 19:43:59 UTC
Actually, upstream has a long issue of users (many from other distros, but also Fedora), where they complain about this exact thing: https://github.com/nextcloud/desktop/issues/427

Comment 4 Carlos Mogas da Silva 2019-05-25 18:18:43 UTC
Problem still valid for Fedora 30

Comment 5 Simon 2019-06-11 19:24:12 UTC
I also experienced this issue in Fedora 30 (the XFCE spin).

The fix mentioned on the upstream GitHub issue worked instantly, i.e. libgnome-keyring should be a dependency for nextcloud-client.

Comment 7 Germano Massullo 2019-10-04 13:29:31 UTC

*** This bug has been marked as a duplicate of bug 1652973 ***


Note You need to log in before you can comment on or make changes to this bug.