Bug 165312 - FC4 install hangs immediately after CD check question in text or GUI
FC4 install hangs immediately after CD check question in text or GUI
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-08-07 13:03 EDT by Cokey de Percin
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 05:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cokey de Percin 2005-08-07 13:03:04 EDT
Description of problem:

I have a system that has been running RH 7.3 for a number of years and which I'm
now trying to install FC4 on.  The system uses a Tyan Thunder 2500 (S1867)
mother board (ServerWorks OSB4 chip set) with the on board SCSI (53C1010) and
network controller (Intel) turned off. The network controller because it seemed
to be having problems and was replaced with a 3Com and the SCSI because it
doesn't seem to work correctly with them 'new' Symbios driver. For storage, it
has a Mylex DAC960 (model 1100) dual channel hardware RAID controller attached
to 4 18G drives (2 per channel) for primary boot and a Symbios 53c896 dual
channel SCSI controller with various drives/cdrom/DVD/tape hung off it.  There
is also a 3Com 3c905C-TX network card, NetMos Technology VScom 021H-EP2 2 port
parallel adapter and an on board S3 Inc. 86c368 video controller.

The problem is that the installation (text or GUI) hangs solid almost
immediately after it asks about checking the CD, leaving a blank blue screen. 
Note that I have checked the CD's and have installed FC4 from these CD's on two
other machines, so I don't think the problem is with the CD's.  Note also that
SUISE 9.1 & 9.2 don't seem to have this problem.  I haven't installed them as
I'm not interested in using them, but they do boot correctly and start the GUI
or text install with the correct drivers loaded.  I've tried various install
parameters but haven't found any combination that helps.

Screen #3 shows:
...
load module set done
loading parallel port driver...
modules to insert parport parport_pc
loaded parport form /mnt/runtime/modules/modules/modules.cgz
loaded parport_pc from /mnt/runtime/modules/modules/modules.cgz
inserted /tmp/parport.ko
(end)

Screen #4 shows:
...
(Raid installed - MD etc)
JFS nTxBlock = 8192 nTxLock = 65536
SGI XFS with ACL's, security attribures, large block numbers, no debugging enabled
SGI XFS Quota Management Subsystem
device mapper: 4.4.0-ioctl (2005-01-12) initialized: dm-devel@redhat.com
(end)


Version-Release number of selected component (if applicable):
n/a

How reproducible:

Steps to Reproduce:
1. Boot from FC4 CD #1 
2.
3.
  
Actual results:
Hangs after asking to check CD.  Note that CD has been checked.

Expected results:
Continue in the install

Additional info:
Comment 1 Jeremy Katz 2005-08-08 18:15:10 EDT
Does booting with 'linux nofb' help?
Comment 2 Cokey de Percin 2005-08-25 16:39:54 EDT
I appologize for the delay, been out of town...  That doesn't help.  Stops in
exactly the same place.  Also tried, singlely and in various combinations with
nofb: noapic and skipddc
Comment 3 Jeremy Katz 2005-08-30 14:36:31 EDT
Are the keyboard leds blinking when it hangs?  Does the sysrq key still show
output on tty4?
Comment 4 Cokey de Percin 2005-09-04 12:55:49 EDT
Keyboard led are off and do not blink.  Sysrq key does nothing.  Ctrl-Alt-Fn
keys do nothing.  Display is stuck on whatever tty was being displayed at the time.
I'm this is a problem with the device mapper or the parallel port device driver.
Note that immediately after "inserted /tmp/parport.ko" there should be 
"inserted /tmp/parport_pc.ko" and immediately after the "device-mapper" line
there should be a number of parport information lines.
Comment 5 Dave Jones 2005-09-30 05:37:18 EDT
The only thing I can suggest is to try booting with acpi=off. If that doesn't
fix it, it likely needs a newer boot kernel, and we lack the mechanism to respin
an iso with an updated kernel, so if that doesn't work, you're stuck until fc5.
Comment 6 Dave Jones 2005-09-30 19:53:41 EDT
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.

Note You need to log in before you can comment on or make changes to this bug.