Bug 1653424 - There should be no select all option if all the hosts are listed on single page.
Summary: There should be no select all option if all the hosts are listed on single page.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Search
Version: 6.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Omkar Khatavkar
URL:
Whiteboard:
: 1653423 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 19:54 UTC by Suraj Patil
Modified: 2020-07-06 14:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-06 14:40:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot1 (109.59 KB, image/png)
2018-11-26 19:55 UTC, Suraj Patil
no flags Details
screenshot2 (104.73 KB, image/png)
2018-11-26 19:55 UTC, Suraj Patil
no flags Details

Description Suraj Patil 2018-11-26 19:54:41 UTC
Description of problem:
If we have searched for something on the content host page and if the search result list all the hosts on the single page, then there should be no "select all X" option. 
If all the hosts are listed on the single page and click the "select all X" option, after that if we go to select action > manage errata it through the below error.
----------------------------------------------------------------------
Your search query was invalid. Please revise it and try again. The full error has been sent to the application logs.
----------------------------------------------------------------------

Please see the screenshots for more details. 


Version-Release number of selected component (if applicable):
satellite 6.4

Steps to Reproduce:
1. Go to satellite web UI > content hosts
2. Search for anything in the search bar.  
3. select all the hosts. 
4. click on "select all X" option
5. click on select action button > manage errata

Actual results:
Your search query was invalid. Please revise it and try again. The full error has been sent to the application logs.

Expected results:
should list the errata.

Comment 1 Suraj Patil 2018-11-26 19:55:11 UTC
Created attachment 1508655 [details]
screenshot1

Comment 2 Suraj Patil 2018-11-26 19:55:36 UTC
Created attachment 1508656 [details]
screenshot2

Comment 3 Marek Hulan 2018-11-27 14:29:58 UTC
*** Bug 1653423 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2020-06-09 15:00:37 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 6 Bryan Kearney 2020-07-06 14:40:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.