Bug 1653613 - [Dalton] Optimize for virt store fails with distribute volume type
Summary: [Dalton] Optimize for virt store fails with distribute volume type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: RHGS 3.4.z Batch Update 3
Assignee: Krutika Dhananjay
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1638674
Blocks: 1654138
TreeView+ depends on / blocked
 
Reported: 2018-11-27 09:48 UTC by SATHEESARAN
Modified: 2019-06-18 10:39 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.12.2-33
Doc Type: Bug Fix
Doc Text:
Earlier, enabling group "virt"failed on non-replicate volumes due to the existing replicate-specific options in the group. As a result, the options that could optimize the volume for virtual machine storage was not set on distributed volumes. This release introduces a new group'’distributed-virt' to optimize the deployment of distributed volumes in the virtual machine storage.
Clone Of: 1638674
: 1654138 (view as bug list)
Environment:
Last Closed: 2019-02-04 07:41:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0263 None None None 2019-02-04 07:41:53 UTC

Description SATHEESARAN 2018-11-27 09:48:54 UTC
Description of problem:
-----------------------
Fails to set group virt option on distribute volume type since some of the options are specific to replica volume types.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHGS 3.4 Batch Update1

How reproducible:
------------------
Always

Steps to Reproduce:
--------------------
1. Create a distribute volume and select optimize for virt store

Actual result:
--------------
Fails to set all volume options on the distribute volume

Expected result:
----------------
Create a separate virt profile with volume options applicable for distributed volume

Comment 1 Atin Mukherjee 2018-11-27 14:30:53 UTC
Krutika - I'm assigning this to you. Seems straight forward.

Comment 2 Krutika Dhananjay 2018-11-28 03:10:32 UTC
(In reply to Atin Mukherjee from comment #1)
> Krutika - I'm assigning this to you. Seems straight forward.

Indeed it is! But even before that, do you mind responding to https://bugzilla.redhat.com/show_bug.cgi?id=1638674#c6 ?

-Krutika

Comment 3 Atin Mukherjee 2018-11-28 06:35:29 UTC
Response has been captured at the RHHI BZ.

Comment 4 Atin Mukherjee 2018-11-28 08:30:38 UTC
upstream patch : https://review.gluster.org/#/c/glusterfs/+/21735/

Comment 7 Krutika Dhananjay 2018-12-13 05:33:33 UTC
RHGS-specific patch posted downstream - https://code.engineering.redhat.com/gerrit/#/c/158487

Comment 11 SATHEESARAN 2019-01-09 06:34:22 UTC
Tested with glusterfs-3.12.2-35.el7rhgs.

Optimizing the distributed volume for virt store case is made possible using 'distributed-virt' profile

[root@ ~]# gluster volume set dvol group distributed-virt
volume set: success

[root@ ~]# gluster volume info dvol
 
Volume Name: dvol
Type: Distribute
Volume ID: 78168ec8-1abe-4f9a-a3dd-a1b76414fac3
Status: Created
Snapshot Count: 0
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: host1.redhat.com:/tmp/1
Options Reconfigured:
performance.client-io-threads: on
server.event-threads: 4
client.event-threads: 4
user.cifs: off
features.shard: on
network.remote-dio: enable
performance.low-prio-threads: 32
performance.io-cache: off
performance.read-ahead: off
performance.quick-read: off
transport.address-family: inet
nfs.disable: on

Comment 12 Srijita Mukherjee 2019-01-20 19:24:42 UTC
The doc text has been updated. Kindly review the technical accuracy.

Comment 13 Krutika Dhananjay 2019-01-21 05:34:00 UTC
(In reply to Srijita Mukherjee from comment #12)
> The doc text has been updated. Kindly review the technical accuracy.

Looks good to me.

Comment 15 errata-xmlrpc 2019-02-04 07:41:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0263


Note You need to log in before you can comment on or make changes to this bug.